Donnerstag, 18. Oktober 2018, 23:33 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Ganesha

unregistriert

21

Freitag, 3. Februar 2012, 16:37

RE: Neue Technik - alter Fehler Kombititel

Jetzt mache ich erst einmal einen Spaziergang, das kühlt heute schön ab, der Kombititel nervt.
Hallo,

gleicher Fehler wie beim ersten Posting: Keine vollständigen Informationen. :-)

Möglicherweise ist es eine Variante von diesem Thema: Fehlerhafte Daten bei Kombititel

Aber könnte auch was anderes sein.
Beschreibe doch mal welche Tickdaten-Titel Du hast (und wie groß sie sind), sag wie Du die in den Kombititel eingefügt hast, wie der Kurs aussieht (also Kursreihe vollständig und so) und welche Einstellungen Du bei Investox-Leistungsschemen hast. Dann ob virtueller Broker oder was anderes. Dann was da genau wackelt. Also das sich der PL im Laufe eines Trades ändert, halte ich für normal. :)

PIcasso

Fortgeschrittener

Registrierungsdatum: 26. August 2011

Beiträge: 151

22

Freitag, 3. Februar 2012, 19:02

Fehleranalyse Kombititel - die Ursache

Hallo Ganesha,

jetzt habe ich das mal in der Zeitstrecke Stück für Stück rückwärts betrachten, um den Fehler einzugrenzen.

Zuerst als Datumsabgrezung den 27.2.2012 eingegeben, da war noch alles o.k.

Dann den 20.1., dann den 10.1., noch alles o.k.

Aber beim 1.1. war der Fehler da und ich bin einfach mit dem Datum nach vorne gegangen.

So fand ich den fehler am 5.1.2012, da war ein Trade um 9:25, dann verschwand er wieder, dann war er wieder da.

(ich habe Komprimierung 5 Minuten und handle kurzfristig Intraday)

Dann entdeckte ich am 5.1., aber ca. 2 Stunden später eine Kurslücke von ca. 2 Stunden.

Diese Kurslücke war auch ausserhalb des Trades, der vorher auf Stop lief (wenn er gerade mal sichtbar war).



Das heißt jetzt, es gab am 5.1. bei der Datenübertragung technische Probleme der Kursversorgung,

die sich auf das HS auswirken. Dabei war die Kursversorgung aller Titel gestört, die sich aber dann nicht auf die originaltitel auswirkte,

den ich konnte den Kombititel austauschen und den Originaltitel DAX einsetzen, dann lief es ohne Probleme, obwohl da auch die Lücke ist.

Das heißt jetzt, Kurslücken an einem Handelstag haben Auswirkungen auch zu anderen Zeiten an dem Tag, in denen der Trade gerade nicht lief, zumindest rückwirkend betrachtet.

Das heißt jetzt aber auch, Vorsicht bei Kombititeln, weil hier die Datenqualität eine andere ist oder weil der Zugriff anders erfolgt.



Ich habe dann im HS den Tag ausgeschlossen, dann gab es keine Probleme mehr, bis ich das Datum zur Kontrolle einen weiteren Monat zurück setzte. So fand ich noch einen 2. Fall am 7.12., wo die Datenunterbrechnung um 20:15 war. Obwohl ich hier nur bis 18:00 handle, hatte er an dem Tag auch den Trade um 8:45 angezeigt, dann wieder nicht usw.

Das bestätigt nochmals, Datenunterbrechnung am Tag haben Auswirkungen bei den Kombititeln sogar schon an dem Tag am Morgen.

Allerdings, damit das nicht falsch verstanden wird.

Am 7.12. um 8:45 war ja alles noch normal, deshalb war da beim Handel natürlich noch keine Störung, die kam erst später.

Die wirkt sich aber auf die Ergebnisanzeige aus, die schwankt teilweise um 5% (Profitable Trades), damit ist naürlich schwer zu testen.

Ich hatte aber in diesem Zeitraum danach auch zweimal andere Probleme im Echtbetrieb, bei den Ordern.

Das habe ich aber jetzt nicht mehr so genau im Kopf, das hängt vermutlich damit zusammen.



Damit stellen sich natürlich die Fragen, was sollte man tun, wenn es diese Kursunterbrechnungen gibt???

Ich kann die natürlich mit Datum nachträglich ausgrenzen, um nicht mehr die Probleme zu erzeugen.

Aber da müßte ja jedes HS mit einem Datum versorgt werden.

Die Datenkorrektur mit Import ist da nur für die möglich, die nochmals an die alten Daten kommen.

Eine kurslücke im Kombititel "bekannt" geben, geht das?



Picasso

Bernd

Erleuchteter

Registrierungsdatum: 5. Juni 2005

Beiträge: 3 898

Wohnort: Iringsweg

23

Freitag, 3. Februar 2012, 21:07

Wie schon von Ganesha angemerkt fehlen weiter vollständige und exakte Informationen.

Am einfachsten ist es, wenn Du Hardcopies aller Kombititel (KT) Einstellungen postest. Ich kann aus Deinem Posting nur rauslesen, dass Du irgendwie mit KTs Probleme hast und es mit Kurslücken vielleicht (?) zu tun hat.

Was man ja nicht weiss ist, hast Du Filter aktiviert im KT, vielleicht auch noch eine VBS Formel, ist ein Haken gesetzt oder nicht bei Kurslücken nicht füllen, sind die Einzeltitel in der korrekten Reihenfolge, stimmen die Übergangsdaten (Rollover) usw. Bitte fang nicht an, das jetzt wieder mit Worten zu beschreiben, was Du eingestellt hast: warum nicht einfach die vollständige Definition als Hardcopy hier reinkopieren?

Auch: gibt es Fehlermeldungen im Log während der KT und seine Bestandteile eingelesen werden (wenn ja: nicht mit Deinen eigenen Worten umschreiben, sondern exakte Fehlermeldung abliefern) oder später während der Verarbeitung?

Liegen dann vollständige und exakte technische Informationen vor kann man es entweder beurteilen, oder Herr Knöpfel hat alle Daten zur Problemlösung an der Hand, falls Du doch wirklich auf einen Fehler gestossen bist ...

Ich arbeite jeden seit Jahren nur mit KT's und habe keine der geschilderten Probleme.


PS: vergiss neben den Hardcopies bitte auch nicht, die genaue Investox Versionsnummer mit anzugeben; auch zusätzliche Hardcopies, wie der Fehler im Chart aussieht, wäre sicher nützlich. Man sagt, ein Bild sagt mehr als tausend Worte.
Gruss
Bernd

-----------------------------------------------
http://www.13quants.ch

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Bernd« (3. Februar 2012, 21:26)


PIcasso

Fortgeschrittener

Registrierungsdatum: 26. August 2011

Beiträge: 151

24

Freitag, 3. Februar 2012, 22:35

HC

Hallo Bernd,

die Anlage mit Hardcopy war zu groß, die konnte ich nicht hochladen, dann nahm er .doc auch nicht.
ich versuchte das direkt hier rein zu kopieren, mit Bild einfügen, das ging auch nicht,

skript eingabeaufforderung, url des bildes eingeben.

brrrt, bild einfügen, da müßte ich eine datei mit einem ganz anderen format erstellen.
Meine Investox-Schlüsselnummer möchte hier aber nicht einstellen, sonst kan das ggf. "falsch" verwendet werden.
Ich schicke den schlüssel an Hr. Knöpfel per Mail, dann braucht der nicht suchen und schicke da auch den hardcopy mit.

Wir können das nächste Woche in aller ruhe klären.

Wichtige Hinweis aber noch, wenn mein RTT abgeschaltet ist, kommt das Problem nicht.
Das habe ich jetzt gerade noch erkannt, weil ich außerhalb der Handelszeit das versucht habe.


Picasso

Ganesha

unregistriert

25

Freitag, 3. Februar 2012, 22:53

RE: HC

brrrt, bild einfügen, da müßte ich eine datei mit einem ganz anderen format erstellen.

Bitte als jpg oder png. Man bekommt ein Bild des Kombi-Dialogs mit < 30kb hin.

Bernd

Erleuchteter

Registrierungsdatum: 5. Juni 2005

Beiträge: 3 898

Wohnort: Iringsweg

26

Sonntag, 5. Februar 2012, 01:40

Meine Investox-Schlüsselnummer möchte hier aber nicht einstellen, sonst kan das ggf. "falsch" verwendet werden.

Hä bitte? Was meinst Du mit Schlüsselnummer und was hat das mit dem vorliegenden Problem zu tun?

Edit: nochmals durchgelesen; meinst Du meine Frage nach der Investox Versionsnummer?, die hat nichts mit dem Investox Key zu tun und ist sicher auch nicht geheim. Meine Life Maschine läuft derzeit beispielsweise auf Investox V 6.3.3, also wieso sollte man das nicht schreiben können? Oder meinst Du was anderes? Jedenfalls ist zur Beurteilung eines Problems meist die genaue Versionsnummer eines Programmes nötig, weil manche Fehlersituationen oft schon durch neuere Updates adressiert wurden. Wie soll man was konkretes schreiben, wenn man nicht weiss, ob Du vielleicht noch eine alte V5 oder gar V4 am Start hast?
Gruss
Bernd

-----------------------------------------------
http://www.13quants.ch

PIcasso

Fortgeschrittener

Registrierungsdatum: 26. August 2011

Beiträge: 151

27

Sonntag, 5. Februar 2012, 13:47

version

Hallo bernd,

da hatte ich Dich falsch Verstanden, ich dachte Du meinst die Bestell-/Lizenznummer

Ich hatte am 1.1. den Update auf 6.3.2 gemacht und vor einer Woche auf 6.3.3., habe also die neuste Version für XL.



Die Hardcopys stelle ich heute noch nachfolgend zusammen und hier ins Portal.



Picasso

PIcasso

Fortgeschrittener

Registrierungsdatum: 26. August 2011

Beiträge: 151

28

Sonntag, 5. Februar 2012, 14:30

Hardcopys

Der erste Trade des Tages am 5.1. verschwindet und taucht dann wieder auf, im Wechsel alle paar Sekunden. Das ist nicht der Fall, außerhalb der Handelszeit. Da er mal da ist, mal nicht, wirkt sich das auf die Ergebnisanzeige aus.

Aber ich vermute auch die Probleme bei meinen fehlerhaften Ordern, die ich schon ein paarmal hatte. Z.B. die Sicherheitsstops fehlten. Kurz nach 11 Uhr war dann die Kurslücke bei ALLEN Titeln (Übertragsprobleme Kurse).



Der gbm ist hier der Titel, der gehandelt wird. Oder auch der Bund

Der Dax ist der Kombititel, der in der HS abgefragt wird. Z.B.

Calc XDROC: ROC(GD(Obos("KOMBI_DAX_5M",Close, 20), 3, E), 1, $) < 0;

calc xdcross: (Cross(GD(StochRSI("KOMBI_DAX_5M",Close, 14, 14), 6, E), [44,1,100,1,100,10,3,I] , 5) = -1);



Wenn der Kombi_DAX_5M ausgetauscht wird mit dax@... , ist der fehler weg.

Der Fehler tritt nur auf, wenn der Kombititel in einem Indikator angesprochen wird.

Analoges Problem am 7.12.



Ich hatte jetzt nur die Möglichkeit das etwas umständlich mit Einzeldateien zu erstellen, muss ich in mehrere Teile machen..
Falls noch ein HC fehlt, liefere ich das nach. Kurslücken füllen habe ich jetzt nicht gefunden, wo das steht.

Picasso


PIcasso

Fortgeschrittener

Registrierungsdatum: 26. August 2011

Beiträge: 151

29

Sonntag, 5. Februar 2012, 14:32

Hardcopy 2. Teil


PIcasso

Fortgeschrittener

Registrierungsdatum: 26. August 2011

Beiträge: 151

30

Sonntag, 5. Februar 2012, 14:36

Hardcopy 3. Teil





12 und 13 nochmals, das hochladen ging wohl nicht richtig.



picasso

PIcasso

Fortgeschrittener

Registrierungsdatum: 26. August 2011

Beiträge: 151

31

Sonntag, 5. Februar 2012, 14:48

chart

Hier ist noch der Chart.



Picasso

PIcasso

Fortgeschrittener

Registrierungsdatum: 26. August 2011

Beiträge: 151

32

Montag, 6. Februar 2012, 07:38

klein

hoffentlich kann man das lesen (zoom), ist ziemlich klein.

aber anders habe ich die bilder nicht rein gebracht.



picasso

PIcasso

Fortgeschrittener

Registrierungsdatum: 26. August 2011

Beiträge: 151

33

Montag, 6. Februar 2012, 15:39

Hinweis

Hallo Bernd,

damit Du jetzt nicht umsonst suchst.

von Hr. Knöpfel habe ich eine Korrekturversion erhalten,

wir testen noch, ist noch nicht ganz o.k.

Wenn das fertig gelöst ist, gebe ich eine Meldung hier ein.



Picasso

Bernd

Erleuchteter

Registrierungsdatum: 5. Juni 2005

Beiträge: 3 898

Wohnort: Iringsweg

34

Montag, 6. Februar 2012, 15:57

Hallo Picasso

Das hatte ich aufgrund der Datenlage mit den geposteten Hardcopies bereits vermutet und deshalb abgewartet. Danke auf jeden Fall für das Feedback.

Prima, dass Du es doch geschafft hast, die Hardcopies hier reinzustellen! Wenn man sie anklickt und dann auf die Lupe, sind sie einwandfrei zu lesen, übrigens.
Gruss
Bernd

-----------------------------------------------
http://www.13quants.ch

PIcasso

Fortgeschrittener

Registrierungsdatum: 26. August 2011

Beiträge: 151

35

Mittwoch, 8. Februar 2012, 08:30

mit 6.3.4 behoben

Hallo,

ich gebe noch eine Abschlussmeldung ein.

Mit der Version 6.3.4, die ich vorab bekommen und getestet habe, ist der Fehler beseitigt.



Vielen Dank hr. Knöpfel für die schnelle Reaktion und die Korrekturversion.



Vielen Dank auch Ganesha, auch wenn der Fehler anders war, mit Deinem Vorschlag habe ich wieder eine neue Technik dazu gelernt.



Picasso :) :) :)

Ganesha

unregistriert

36

Mittwoch, 8. Februar 2012, 11:35

RE: mit 6.3.4 behoben

Ganesha, auch wenn der Fehler anders war, mit Deinem Vorschlag habe ich wieder eine neue Technik dazu gelernt.
Lass mich raten ... Vollständige Fehlerbeschreibungen posten? :thumbsup: