Montag, 27. Mai 2019, 10:30 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

felixhn Männlich

Benutzer

Registrierungsdatum: 1. März 2004

Beiträge: 63

Wohnort: Kiel

1

Mittwoch, 15. Mai 2019, 20:13

Backfill startet nicht

Hallo,
seit der Aktualisierung auf die neue API und die aktuelle RTT-Version habe ich das Problem, dass ein manuell gestarteter Backfill nicht startet. Die Fehlermeldung lautet "IB-Backfill: Über das Ende des Datenstroms hinaus kann nicht gelesen werden. (-1)"


API 9.76
Gateway Build 976.2e

RTT 3.5.0

Hat jemand das bereits erlebt?

Grüße,
Felix

Karlson

Besucher

Registrierungsdatum: 6. April 2010

Beiträge: 3

2

Donnerstag, 16. Mai 2019, 14:17

Hallo,
bei mir funktioniert der automatische sowie der manuelle Backfill.
TWS 976.2f
API 9.75.01
RTT 3.5.0
XL 7.6.0
Gruß,
Karlson

Wiwu Weiblich

Meister

Registrierungsdatum: 4. September 2002

Beiträge: 1 655

Wohnort: Neuenhagen b. Berlin

3

Donnerstag, 16. Mai 2019, 17:22

Hallo,

hier gibt es ebenfalls keine Probleme mit dem manuellen und automatischen Backfill.

TWS 976.2d
API 9.75.01
RTT 3.5.0
XL 7.6.0


Zitat

Über das Ende des Datenstroms hinaus kann nicht gelesen werden. (-1)"


Dann prüfe bitte auch einmal die folgenden Einstellungen:

in der TWS unter : Einstellungen API >>> Einstellungen >>>> vertrauenswürdige IP : 127.0.0.1 = gesetzt >>> Häkchen bei "nur Verbindungen vom lokalen Host zulassen = gesetzt
in RTT für IB unter: Optionen >>> Verbindung zu IB einstellen >>>> Feld IP-Adresse = leer
Viele Grüße von Anke

http://www.ascunia.de

felixhn Männlich

Benutzer

Registrierungsdatum: 1. März 2004

Beiträge: 63

Wohnort: Kiel

4

Donnerstag, 16. Mai 2019, 19:33

Hallo,

vielen Dank für Eure Unterstützung.

Auch nach der Umsetzung von Ankes Tips ist das Ergebnis leider unverändert. Ich werde weiter experimentieren.

Aber nochmals vielen Dank!

Viele Grüße,
Felix

Wiwu Weiblich

Meister

Registrierungsdatum: 4. September 2002

Beiträge: 1 655

Wohnort: Neuenhagen b. Berlin

5

Donnerstag, 16. Mai 2019, 20:04

Hallo Felix,

dann liegt es möglicherweise an der API-Version.
Die 975.01 steht auf der IB-Webseite ja nicht mehr zum Download bereit.

Wenn Du willst, kannst Du mich aber gern direkt anschreiben.
Ich hab mir die V 975.01 abgespeichert und kann sie Dir mailen.
Viele Grüße von Anke

http://www.ascunia.de

Investox

Administrator

Registrierungsdatum: 31. August 2002

Beiträge: 5 582

6

Freitag, 17. Mai 2019, 10:02

Hallo,

keine Probleme hier mit der API 9.76, auch der Backfill funktioniert.

Viele Grüße
Andreas Knöpfel

felixhn Männlich

Benutzer

Registrierungsdatum: 1. März 2004

Beiträge: 63

Wohnort: Kiel

7

Freitag, 17. Mai 2019, 16:09

Hallo,

mit der 975.01 hat es jetzt geklappt.

Viele Grüße und nochmals vielen Dank,
Felix

Bernd

Erleuchteter

Registrierungsdatum: 5. Juni 2005

Beiträge: 3 935

Wohnort: Iringsweg

8

Mittwoch, 22. Mai 2019, 19:06

Hallo Felix

Wann passiert denn die Fehlermeldung genau?
Über das Ende des Datenstroms hinaus kann nicht gelesen werden

Diese Meldung habe ich einmal die Woche auf drei Maschinen und 6 RTT/IB Instanzen aktuell, und zwar punktgenau Sonntags.

Da ich zu diesem Zeitpunkt auch die TWSe neu starten muss "aus neuen blöden Interactivebrokers-hausgemachten Gründen", ist es für mich seiten Investox nicht sehr schlimm, ich bin ja eh schon angeloggt wegen IB.

Ich starte die TWSe also am Sonntag später Abend neu, und weiss schon, egal wie lange ich warte, RTT/IB wird diese Mdlung nicht überwinden (*). Also schliesse ich meine RTT/IB Instanzen und starte sie dann neu. Dann geht

Ist es bei Dir auch so, oder anders? Wie? Wie sind die Zeitpunkte, wenn diese Meldung kommt?


*) Witzigerweise, seit dem letzten Investox-Update: die Investox Instanzen selber überleben nun ohne Neustart, auch für Wochen, nur RTT/IB schafft es nicht und scheitert am "Über das Ende des Datenstroms hinaus kann nicht gelesen werden". Aber egal, Schlamm drunter, irgendwas ist ja immer.
Gruss
Bernd

-----------------------------------------------
http://www.13quants.ch