Donnerstag, 18. Oktober 2018, 08:17 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: INVESTOX-Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

sten

Erleuchteter

Registrierungsdatum: 6. September 2002

Beiträge: 2 879

1

Mittwoch, 11. August 2004, 10:59

RTT: nach Titelneuaufnahme gehen andere nicht mehr

Gerade habe ich den komplette Eintrag verloren, also gebe ich nochmal alles ein. Ich werde jetzt sicherheitshalber zwischendurch abspeichern...

Hallo,

sorry, ich habe vor ein paar Tagen die Aktie DIA zur Kursdatenaufzeichnung mit hinzugefügt. Zuerst hat bid & ask nicht funktioniert, dann habe ich die gleiche ID wie bei der Closekursaufzeichnung auch für bid & ask verwendet und alles hat funktioniert.
Ich war happy, daß ich gleich für alle anderen Titel nur noch eine ID für Kurs, bid und ask so umkonfiguriert habe.
Aber am nächsten Tag hat die Kursaufzeichnung nicht mehrfunktioniert, leider aber auch bei den Titel Microsoft und Öl-Future, die vorher gelaufen sind. Daraufhin habe ich DIA komplett aus dem RTT-Tool gelöscht, aber ohne Erfog, die anderen beiden wollen immer noch keine Kurse wieder aufzeichnen.
Jetzt bis ich extrem verunsichert, weil ich mich nicht traue noch mehr am RTT-Tool herum zu konfigurieren und die ganze Sache noch weiter zu "verschlimmbessern".

Ich würde mir folgende Erweiterungen beim RTT-Tool wünschen:
1.) Fehlerprotokoll
Zur Fehleranalyse wäre ein Fehlerprotokoll sehr hilfreich, auch könnte man es zur Not Hr. Knöpfel diese Informationen, zur genauen Fehleranalyse zukommen lasse.

2.) Laden und Speichern einer Konfiguration
Ich könnte mich "Kreuzweise", weil ich nachdem endlich alles gelaufen ist, noch den blöden DIA-Wert dazu konfiguriert habe. Was würde ich jetzt dafür geben, einfach die alte Konfiguration wieder laden zu können und Microsoft & Öl-Future funktionieren wieder.

3.) keinen Neustart des RTT-Tools mehr bei Umkonfigurationen
Wenn von 40 Titel nun 9 Titel nicht funktionieren und man fängt an herumzukonfigurieren, dann muß man nach jeder Änderung bzw. neue Herumprobieren, das RTT beenden. Dadurch kommt es aber auch zu einen Datenverlust bei den ok-Werten. Und da es viele mögliche Varianten gibt, werden alle Auszeichnungen zerstückelt.
Könnte man das nicht irgendwie hinbekommen, daß man nicht alles neu starten muß?

4.) Gesamtübersicht aller Titel-Konfigrationen
Die ID-Umstellung hat über 1h gedauert und ich habe alles noch 3x kontrolliert. Z.B. die IDs können nur mit mehreren Klicks erreicht werden, sind sehr zerstreut und bei 40Titeln kommen schon mehrer 100 Klicks zusammen. Und auch nach 1h bin ich nur zu 99% sicher, daß mir vielleicht nicht doch eine ID "durch die Lappen gegangen ist".
Eine Überprüfung könnte viel schneller gehen, wenn alle Konfigurationsdaten in einem Protokoll zusammengefasst werden, ähnlich wie es bei Investox eine Info-Seite bei Handelssystemen gibt.

5.) RTT zeigt an alles okay, aber es werden keine Kurse aufgezeichnet
Leider sieht man das erst, wenn man sich die konkreten Kurswerte ansieht und das Datum/Uhrzeit vergleicht. Das ist bei 40 Titeln ziemlich umständlich.
Könnte man hier nicht einen Wächter/Visualisierung einbauen, so daß man das Problem mit einen Blick erkennen kann?

6.) mehr Intelligenz im RTT einbauen
Z.B. wenn man eine neuen DDE-Link anlegen möchte im RTT-Tool, aber die TWS diesen überhaupt nicht mehr unterstützen möchte, dann wäre hier eine Warnung sehr hilfreich.

Vielleicht läßt sich in dieser Richtung was machen. Es würde die Supportmöglichkeiten sehr unterstützen. Mir ist durchaus bewusst, daß die meisten Probleme ihre Ursache nicht im RTT sondern mit den permanenten Änderung der TWS zu tun haben.

Viele Grüße
Torsten

Dieser Beitrag wurde bereits 13 mal editiert, zuletzt von »sten« (11. August 2004, 11:43)


Investox

Administrator

Registrierungsdatum: 31. August 2002

Beiträge: 5 568

2

Mittwoch, 11. August 2004, 14:52

RE: RTT: nach Titelneuaufnahme gehen andere nicht mehr

Hallo,

danke für die Vorschläge. Es geht hierbei ja um die Anbindung an IB per DDE.
zu 1,5,6): Ein Nachteil von DDE ist, dass es hier kaum Rückmeldungen bei Problemen gibt. Es gibt gflls. nur die Meldung, dass die Verbindung nicht zu Stande kommt - der Titel ist dann inaktiv und zeigt dies an. Wenn auch diese Rückmeldung nicht kommt ist der Titel aktiv, obwohl keine Daten eintreffen (hier hilft dann gflls. nur die Datenfeed-Überwachung von Investox selbst). Ein "Fehlerprotokoll" könnte also auch nur sagen, dass der Titel nicht aktiviert werden konnte.
zu 2) Könnte man machen. Eine andere Möglichkeit wäre die Sicherung der RealtimeDef.dat (siehe RTT-Handb. S. 13).
zu 3) Ist da ein Neustart wirklich immer erforderlich? Falls ja, so wird dies vom DDE-Server (hier also TWS) "verlangt", nicht von RTT.
zu 4) Ein ID-Protokoll könnte event. hilfreich sein, ist notiert.
Prinzipiell würde ich RTT für IB gerne auf COM umstellen, wobei sich dies m.E. erst lohnt, wenn entweder eine komfortablere Symbolauswahl und/oder Tickdaten-Backfill dadurch ermöglicht würde (eine COM-Anbindung erfordert anders als DDE zudem die Einlog-Bestätigung in die TWS).

Viele Grüße
Andreas Knöpfel

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Investox« (11. August 2004, 14:52)


sten

Erleuchteter

Registrierungsdatum: 6. September 2002

Beiträge: 2 879

3

Mittwoch, 11. August 2004, 18:37

RE: RTT: nach Titelneuaufnahme gehen andere nicht mehr

Hallo,

Danke für die Infos. Habe leider bisher nur das Datenfeed-Auszeichnungsverz. von RTT gebackupt. Habe jetzt umgestellt, so daß ab jetzt auch RealtimeDef.Dat regelmäßig mit gesichert wird.

Viele Grüße
Torsten

sten

Erleuchteter

Registrierungsdatum: 6. September 2002

Beiträge: 2 879

4

Dienstag, 17. August 2004, 17:56

alles wieder okay

Hallo,

jetzt funktioniert wieder alles.
So habe ich es wieder zum laufen gebracht. Scheint ein Problem von der TWS zu sein, was mit einigen hin- und her auch vom RTT-Tool aus gelöst werden kann. Man muß sozusagen den "faulen Titeln" einen "kleinen Schubs" geben.

1.) Habe die bereits aufgezeichneten Kursdateien gesichert.
2.) Dann den RTT-Eintrag komplett gelöscht und alles nochmal neu eingeben. Für den bid und ask-Kursaufzeichnung keinen extra Initialisierungskommand verwendet, sondern die ID vom normalen Closekurs auch hier genutzt.
3.) RTT-Tool und eventuell TWS beenden und nochmal neu starten
--> danach sollte Aufzeichnung laufen, wenn nicht, dann weiter bei 4.)

4.) Doppelklick auf RTT-Eintrag(Closekursaufzeichnung), d.h. es werden die aufgezeichneten Kurse angezeigt. Dann die letzte Zeile löschen und raus aus dem Kursanzeigemodus.
5.) Nur diese eben geänderte Zeile deaktivieren und wieder aktivieren.
6.) Danach sollte die Aufzeichnung wieder loslaufen und einige Sekunden später sollte auch die bid und ask-Aufzeichnung funktionieren (in der Anzeige erscheint "2x aktiv").

Fehlerquelle:
Man sollte sicherheitshalber vorher überprüfen, ob die Zeitbeschränkung aktiv ist und überhaupt eine Kursaufzeichnung zur aktuellen Zeit möglich ist.

Nochmals vielen Dank an Herrn Knöpfel, die Hinweise in der E-Mail haben mir auf jeden Fall weiter geholfen.

Viele Grüße
Torsten

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »sten« (17. August 2004, 18:10)