Mittwoch, 12. Dezember 2018, 16:38 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: INVESTOX-Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Registrierungsdatum: 29. Dezember 2007

Beiträge: 297

Wohnort: Bad Homburg

1

Montag, 5. Mai 2008, 09:50

Order nicht an IB gesendet

Hallo,

irgendwie stehe ich gerade auf dem Schlauch...

Ich bin vor einiger Zeit mit meinem Handelssystem live gegangen und heute morgen wurde auch ein Long Signal erzeugt.

Ich habe die automatische Orderaufgabe bei IB eingeschaltet und bin in der TWS eingeloggt.

Das Verbindungslämpchen leuchtet grün es sollen Juni-FDAX-Kontrakte gehandelt werden aber .....

Es wird einfach keine Order bei IB eingestellt ?????

In der Simulation (Datenfeed mit VB) hat alles immer so schön geklappt... ;(

Was könnte denn falsch eingestellt sein?
Grüße,

Christian

Yoggi

unregistriert

2

Montag, 5. Mai 2008, 09:52

Hallo Christian,

wurden denn im Signalprotokoll Signale angezeigt (Handelssystem - Signalprotokoll)?
Wenn ja, gab es Fehlereinträge im Logbuch?
Yoggi

Registrierungsdatum: 29. Dezember 2007

Beiträge: 297

Wohnort: Bad Homburg

3

Montag, 5. Mai 2008, 10:17

Hallo Yoggi,

es wurden Signale erzeugt. Bessergesagt genau eins - ein Longsignal.

Ich kann es auch im Investoxfenster sehen (Pfeil von unten).

Investox hat auch versucht mir eine Email zu schicken.. Das hat blos nicht geklappt, weil ich wohl bei der Konfiguration einen Fehler gemacht habe.. Das muss ich heute Abend mal nachprüfen... müsste aber mit der Orderaufgabe nichts zu tun haben...

Ich dachte erst, dass Investox erst ab 9:00 die Order einstellt...

Die ersten Kurse des FDAX kommen bei mir aktuell immer deutlich früher (pre open phase) und somit auch das Open Signal....

Aber auch nach 9:00 war immer noch nichts bei IB eingestellt....

Ansonsten gab es keine weiteren Fehler..
Grüße,

Christian

sten

Erleuchteter

Registrierungsdatum: 6. September 2002

Beiträge: 2 879

4

Montag, 5. Mai 2008, 10:41

Hallo Christian,

bist Du sicher, dass Du im OM - Allgemein - Broker - "Interactive Brokers" eingestellt hast.
Du musst zwei grüne Punkte haben, einmal bei der "Automatischen Aktualisierung" und im OM bei aktive Systeme.
Und was man immer wieder schnell vergisst, ist Order - Titeleigenschaften definieren ... hier muß der Tradingwert definiert sein.

Ach ja, passt Deine Investox-Version mit der installierten IB-API zusammen.
Dieses Bundle läuft mit TWS-Paper zusammen.

Zitat

Das Bundle funktioniert:
Inv. 5.2.6
RTT 2.8.8
IB-API 9.41
TWS Build 884.2 vom 29.4.08


Ich hoffe ich konnte weiter helfen.

Viele Grüße
Torsten

Yoggi

unregistriert

5

Montag, 5. Mai 2008, 10:46

Hallo Christian,
ich hatte ähnliche Probleme vor einiger Zeit, daher mein Vorschlag zur Fehlersuche in dieser Reihenfolge:
1.) Ist im Signalprotokoll ein Eintrag vorhanden? Nur das ist wichtig für das reale Handeln, ob Du im Invfenster den Longpfeil sehen kannst ist für die Order völlig unerheblich. Aber wenn Inv versucht hat, Dir eine mail zu schicken, dann ist da wahrscheinlich ein Eintrag vorhanden. Handelssystem-Signalprotokoll nachschauen. Falls da nichts drinsteht, dann passen Deine Einstellungen bzgl. open-close-delay nicht zur realen Handeln.
2.) Ist im Orderbuch von INV ein Eintrag vorhanden?
3.) Wir die Order gefillt?


Ich hatte mal den Fehler gemacht, dass ich vergessen hatte die Titeleigenschaften zu definieren. In der Titelspalte den betreffenden Titel markieren, recht Maustaste - Order-Titeleigenschaften definieren.
Ansonsten bitte die drei Schritte oben durchgehen und mal posten, bis wohin Du gekommen bist.
Alles Gute
Yoggi

Registrierungsdatum: 29. Dezember 2007

Beiträge: 297

Wohnort: Bad Homburg

6

Montag, 5. Mai 2008, 10:54

Hallo Sten, hallo Yoggi,

vielen Dank für eure Antworten.

Die Details kann ich erst heute Abend schicken. Ich muss ja heute leider wieder arbeiten :(

@sten

soweit ich weiss, habe ich diese Varianten installiert + schaue aber heute Abend nocheinmal nach...

@yoggi

es könnte durchaus sich ein Fehler in den Titeleigenschaften eingeschlichen haben.

Ich schicke Dir diese ebenfalls heute Abend. Soweit ich es noch weiss ist der FDAX 06 _kontrakt eingestellt

mit dem Orderplatz DTB
Grüße,

Christian

Registrierungsdatum: 29. Dezember 2007

Beiträge: 297

Wohnort: Bad Homburg

7

Montag, 5. Mai 2008, 17:50

Hallo Yoggi, hallo Torsten,

die Titeleigenschaften sind wie folgt definiert:

Minimale Preisänderung: 0.5
Eingabeschema: IB
Ordergültigkeit: Standard
Symbol: DAX
Börsenplatz: DTB
Typ: FUT
Laufzeit: 06 2008
Währung: EUR


@Torsten
Das Signalprotokoll war bei mir deaktiviert... Ist das ein Problem?

Das Orderbuch und das Depot enthalten beide keine Einträge.

Investox-Version 5.2.1
TWS Built 882.2
RTT 2.8.8
API 9.41


ich steige jeweils zum Open mit delay 0 ein... Müsste somit eigentlich gehen...
Was kann blos falsch sein?
Grüße,

Christian

sten

Erleuchteter

Registrierungsdatum: 6. September 2002

Beiträge: 2 879

8

Montag, 5. Mai 2008, 18:34

Hallo,

beende realTWS und starte paperTWS.
Lösche alle log-Bucheintragungen & Signalprotokoll.

Dann gehe auf das HS das Du verwendest möchtest an und klicke in Investox den Buy oder Sell-Button wodurch Du eine mauelle Order
zu IB über das HS schickst. Entweder es geht und dann siehst Du die Order in der paperTWS oder Investox sagt Dir wo es hackt.
Die Fehlermeldung die ausgegeben werden sind eigentlich sehr griffig und sagen genau wo das Problem liegt.

Viele Grüße
Torsten

PS:
Ein ganz einfacher Fehler der mir machmal passiert ist auch, dass ich bei der Entwicklung die HS-Aktualisierung ausschalte und dann auf "alle 1-Sekunden" vergesse wieder zurück zuschalten.

sten

Erleuchteter

Registrierungsdatum: 6. September 2002

Beiträge: 2 879

9

Montag, 5. Mai 2008, 18:36

Hallo

Zitat

Das Signalprotokoll war bei mir deaktiviert... Ist das ein Problem?


Nein eigentlich nicht. Aber aktiviere es mal, um besser zu sehen was passiert.

Viele Grüße
Torsten

Registrierungsdatum: 29. Dezember 2007

Beiträge: 297

Wohnort: Bad Homburg

10

Montag, 5. Mai 2008, 18:44

Hallo Torsten,

danke für den Tip!
wo bekomme ich denn die paperTWS her?
Die hatte ich bei IB noch garnicht gesehen....
Grüße,

Christian

Registrierungsdatum: 29. Dezember 2007

Beiträge: 297

Wohnort: Bad Homburg

11

Montag, 5. Mai 2008, 19:01

Hallo Torsten,

... ich habe gerade bei IB einen PaperTrader Account angelegt. Es soll morgen zur Verfügung stehen.
Soweit ich es verstanden habe, dann ich die normale TWS - auf dem papertrading account - verwenden um herauszufinden, obs technisch klappt...
Oder?
Grüße,

Christian

Yoggi

unregistriert

12

Montag, 5. Mai 2008, 19:53

Hallo Christian,

ja, ganz normal verwenden wie die reale TWS nur eben beim Einloggen in die TWS das Papertradingkonto nehmen.
Sollten auch im Signalprotokoll - wenn aktiviert - keine Einträge erfolgen, dann kann es sich m.M. nach eigentlich nur noch um Probleme bei der Formulierung der Regeln im Zusammenspiel mit open delay 0 handeln, obwohl open delay 0 ja normalerweise o.k. für reales Handeln ist. Hast Du die Regeln mit Ref -1 formuliert?
Yoggi

Registrierungsdatum: 29. Dezember 2007

Beiträge: 297

Wohnort: Bad Homburg

13

Montag, 5. Mai 2008, 20:29

Hallo Yoggi,

ja, ich habe mit ref -1 gearbeitet. Das System müsste i.O. sein.
Hast Du dir mal die Einstellungen angesehen?
Sind die i.O für ein EoD-System?

Könnte vielleicht auch an dem Virenscanner liegen - ich denke aber das ist ehr unwahrscheinlich...
Ich habe AVIRA installiert + die ActiveX-Verbindungen in TWS freigeschaltet. Ich bekomme auch ein grünes Lämpchen nach IB verbinden angezeigt...
Grüße,

Christian

Yoggi

unregistriert

14

Montag, 5. Mai 2008, 21:02

Hallo Christian,

welche Einstellungen sollte ich mir angesehen haben? Falls du die Titeleigenschaften meinst, die sind o.k.
Mit dem Virenscanner hat es definitiv nichts zu tun, da Du ja im Orderbuch von Investox keine Einträge hast, was bedeutet, dass Inv mit den Einstellungen, die Du vorgenommen hast (Kombination von Regeln und Einstiegsbedingungen) jedenfalls heute morgen kein Signal generiert hat (hat wie gesagt nichts mit den Signalen zu tun, die Du beim Backtest angezeigt bekommst, auch wenn der Backtest sich auch heute morgen bezieht). Beobachte das mal mit dem Signalprotokoll in den nächsten Tagen weiter - am besten auch erst im paperaccount, so würde ich es jedenfalls machen. Eine gute Idee finde ich auch die manuelle Order, damit lassen sich Probleme orten oder ausschließen.
Kopf hoch, es ist zu schaffen!
Yoggi

Registrierungsdatum: 29. Dezember 2007

Beiträge: 297

Wohnort: Bad Homburg

15

Montag, 5. Mai 2008, 21:08

Hallo Yoggi,

Ja, ich meinte die Titeleigenschaften...
Vielen Dank für deine aufbauenden Worte...
Investox scheint ja nicht gerade unkompliziert zu sein :S
Mir ist nicht klar, warum eine Datenfeedsimulation im virtuellen Broker klappt und dann mit einem realen nicht...
Merkwürdig...
Grüße,

Christian

Registrierungsdatum: 29. Dezember 2007

Beiträge: 297

Wohnort: Bad Homburg

16

Dienstag, 6. Mai 2008, 08:30

Hallo,

ich habe jetzt auch eine Fehlermeldung bekommen

Zitat

Fehlende Titeldefinition für DAX-Future (adj.) (Eurex). Sie müssen für den Titel zunächst die Verbindungsdefinitionen angeben.
Was zum Henker ist denn das? Ich dachte die Titelinformationen sind i.O.
Da fehlt doch irgendwas....aber was?? 8|
Grüße,

Christian

Udo Männlich

Vize-Administrator

Registrierungsdatum: 30. August 2002

Beiträge: 8 155

Wohnort: Trade-Planet

17

Dienstag, 6. Mai 2008, 08:47

Hallo Christian,

Du bekommst doch heute den Zugang zum IB-Papertrader? Wenn Du Zugang hast, gib einfach eine manuelle Order ein. Überzeuge Dich vorher noch einmal genau,das Du auf den Papertrader routest. Es kann nicht schief gehen wenn nur der Papertrader auf dem PC geöffnet ist!Wenn die manuelle Order geroutet wird, stimmen die Titeleinstellungen denn sonst würde gar nichts passieren. Wird diese nicht geroutet stimmen die Basis-Einstellungen für den Titel nicht! Eine Ferndiagnose ist hier sehr schwer,da es an zu vielen Knoten hängen kann.Ich möchte davor warnen, vom Investox-Papertrader auf IB-Live zu schalten! Teste besser vorher noch einmal mit dem IB-Papertrader damit es keine ganz bösen Überraschungen gibt!
Happy Trading

Registrierungsdatum: 29. Dezember 2007

Beiträge: 297

Wohnort: Bad Homburg

18

Dienstag, 6. Mai 2008, 09:41

Hallo Udo,

Danke für deine Antwort. Ich werde es mal ausprobieren...

was ist denn genaue eine Titeldefinition?
Grüße,

Christian

Yoggi

unregistriert

19

Dienstag, 6. Mai 2008, 10:08

Hallo Christian,

wie ich oben schon vorgeschlagen hatte:

Ich hatte mal den Fehler gemacht, dass ich vergessen hatte die Titeleigenschaften zu definieren. In der Titelspalte den betreffenden Titel markieren, recht Maustaste - Order-Titeleigenschaften definieren.

Bei den Titeleigenschaften muss man unterscheiden zwischen dem Dialog, den man unter "Order" - "Titeleigenschaften definieren" erreicht (der ist in deinem Fall nicht das Problem) und dem Dialog den man erreicht, wenn man in der Titelspalte den betreffenden Titel markiert - weiter siehe oben. Das war auch damals mein Problem, dass ich annahm, wenn man unter Order alles eingestellt habe, sei damit genug eingestellt - stimmt aber nicht. Probier das mal aus.
Yoggi

Registrierungsdatum: 29. Dezember 2007

Beiträge: 297

Wohnort: Bad Homburg

20

Dienstag, 6. Mai 2008, 10:18

Hallo Yoggi,

das erinnert mich an die "verborgenen Level" der Spiele aus den 80ern.

Dir vielen Dank für den Hinweis :thumbsup: Ich werde es mir ebenfalls ansehen...

Investox ist wirklich ziemlich komplex.

Wenn ich schon - mindestens - der Zweite bin, könnte man folgende Verbesserungsvorschläge definieren:

1.) Gemeinsame Darstellung/Eingabemöglichkeit zum Thema Titel

2.) Aufnahme einer Prüfung von fehlenden Informationen z.B. zum Realhandel in die Plausiprüfung von Investox.
Grüße,

Christian