Mittwoch, 17. Oktober 2018, 17:14 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: INVESTOX-Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

chied

unregistriert

1

Montag, 2. Februar 2009, 08:12

Abgleich Depot / Handelssysteme

Guten Morgen

heute früh hab ich mal mein Depot im ORM auf null gestellt.
Ich hätte nun erwartet, dass zum Open das Depot mit den Positionen im HS abgeglichen werden.
Das heisst, vier GBL Systeme und 4 FDAX Systeme hätten trades generieren müssen (Signale waren da).

Leider haben aber nur zwei GBL Systeme trades generiert. Die restlichen Systeme wurden (trotz selber Einstellungen)
einfach nicht beachtet und dementsprechend wurde das Depot nicht mit den Positionen im HS abgeglichen.

Weiss jemand, woran das liegt?

Vielen Dank und

beste Grüsse

roger

Investox

Administrator

Registrierungsdatum: 31. August 2002

Beiträge: 5 568

2

Montag, 2. Februar 2009, 11:05

Hallo,

>>Die restlichen Systeme wurden (trotz selber Einstellungen)
>>einfach nicht beachtet
>>weiss jemand, woran das liegt?

das Aufspüren der Ursache erfordert eine strukturierte Vorgehensweise:

- Erscheinen zu den fraglichen Systemen Signale im Signalprotokoll?

- Falls nicht, sind die Einstellungen im HS (Aktualisierung etc.) zu kontrollieren.

- Falls ja, es wurden aber keine Orders generiert: dann waren entweder die Systeme im Statusfenster nicht abgehakt oder aber es wurde im Logbuch angegeben, warum keine Order generiert wurde.

Viele Grüße

Andreas Knöpfel

chied

unregistriert

3

Montag, 2. Februar 2009, 16:53

Hallo Herr Knöpfel

vielen Dank, dass Sie sich immer die Zeit für meine Anfragen nehmen.

Zu denn 4 GBL Systemen
8.01 Uhr hatten 2 (GBL I und GBL II) von 4 GBL Systemen Signale generiert und diese auch im Signalprotokoll ordnungsgemäss angezeigt.
Das III System blieb out, demnach korrekterweise auch kein Signal.
Das IV System generierte Enter Signal welches bereits zum Open feststand erst um 11.50 Uhr. Dieses wurde dann auch übermittelt und umgesetzt.
Um 11.48 Uhr wurde ein Gewinnsofortstop bei GBL System II generiert und im Sigbnalprotokoll angezeigt. Jedoch wohl aufgrund der Einstellung
im ORM "Signalbegrenzung auf 1 Signal pro Periode begrenzen" nicht umgesetzt. Hier ist das Problem, dass wenn ich dies Option auf "1 Entersignal"
ändere, die Flattersignale wieder an IB übermittelt und umgesetzt werden.

Zu den 5 FDAX Systemen
Folgende Signale wurden zum gestrigen Close für das heutige Open generiert:
4 mal Enter Short und 1 mal Hold Long.
Effektiv wurde nur das Enter Short Signal um 8.13Uhr (!!!) an das SIgnalprotokoll übermittelt und ausgeführt.
Die restlichen 4 Signale wurden weder an das Signalprotokoll übermittelt noch ausgeführt.

Da alle Systeme mit Sofort-, Kurs und Intradaystops arbeiten laufen sie auf dem IB Titel mit der Aktuallisierung "alle 0 Sekunden".

Im Statusfenster sind alle Systeme abgehackt und die Einstellungen sind in allen Systemen identisch.

Was ist also Ursache dafür, dass
- das Depot nicht mit den Handelssystemen abgeglichen wird (auch nich im Siganlprotokoll)?
- der Sofortstop nicht übermittelt wird ohne Flattersignale zuzulassen?
- Kursstopps erst zum Open der nächsten Periode (= Tag) und ich interday umgesetzt werden?

Vielen vielen Dank und

beste Grüsse

Roger

PS Herr Knöpfel, ich könnte Ihnen die Systeme gerne mal als gesamtes System-Portfolio mit verschlüsselten NN zusenden...

chied

unregistriert

4

Montag, 2. Februar 2009, 16:59

...

Was ist also Ursache dafür, dass
- das Depot nicht mit den Handelssystemen abgeglichen wird (auch nich im Siganlprotokoll)?
- der Sofortstop nicht übermittelt wird ohne Flattersignale zuzulassen?
- Kursstopps erst zum Open der nächsten Periode (= Tag) und ich interday umgesetzt werden?
- Manche Orders im Signalprotokoll mit einer Verspätung von mehreren Minuten generiert und übermittelt werden?

chied

unregistriert

5

Dienstag, 3. Februar 2009, 09:29

Guten Morgen

gestern löschte ich nicht nur mehr alle Depoteinträge sondern auch das gesamte Orderbuch.

Nun wurden heute früh bis auf 2 GBL Systeme alle Signale umgesetzt.
Bei den 2 Systemen (GBL IV und GBL I) die nicht umgesetzt wurden, wurden auch keine Signalprotokolleinträge generiert.
Bei GBL IV wurde das Signal gestern erst um 11.50 Uhr generiert und umgesetzt. GBL I ist heute Out. Dennoch müsste
das Out Signal im Protokoll erscheinen...

Viele Grüsse

Roger

Investox

Administrator

Registrierungsdatum: 31. August 2002

Beiträge: 5 568

6

Dienstag, 3. Februar 2009, 10:13

Hallo,

dann haben Sie es ja schon soweit eingegrenzt, dass es nichts mit der Orderumsetzung (Ordermodul) zu tun hat, sondern mit der Signalgenerierung. Ein Signal kommt nur ins Signalprotokoll (und gflls. Orderrouting), wenn sich das aktuelle Signal bei einer zeitbedingten (!) Aktualisierung ändert.

Der Ablauf ist bei EoD wie folgt (die Einstellungen zu den einzelnen Punkten müssen sinnvoll koordiniert sein):

Kursaktualisierung (z.B. 20 Uhr) -> Zwischenspeicher-Leerung (nach Kursaktualisierung) -> HS-Aktualisierung (nach ZS-Leerung).

Gerade bei EoD-Systemen muss man auf eine gewisse Disziplin achten. Wenn man nach Datenaktualisierung vor der automatischen HS Aktualisierung manuell aktualisiert werden die Signale schon aktualisiert und dann nicht mehr bei der zeitbedingten Aktualisierung protokolliert bzw. geroutet.

Viele Grüße

Andreas Knöpfel

chied

unregistriert

7

Dienstag, 3. Februar 2009, 11:14

Hallo Herr Knöpfel

vielen Dank für die Hilfreiche Antwort.

Nun handelt es sich bei mir um EoD Systeme mit Intradaystops.
Dementsprechend wird das HS über den IB Datenfeed "alle 0 Sekunden" aktualisiert.
Demnach folgen die HS folgendem Ablauf:
Kursaktualisierung laufend über RTT -> Zwischenspeicher-Leerung nur bei Bedarf -> HS-Aktualisierung

Nur so können doch die Sofort- und Intradaystops ausgelöst werden. Dies verursacht aber ein Problem mit
den Kursstops wie mir Frau Beyer mitteilte. Wie wäre dieses Problem zu beheben? Oder werden die Stops nicht durch
"auf 1 Signal pro Periode begrenzen" unterdrückt, da die Stops ja als Entry Order aufgegeben werden?

>>Wenn man nach Datenaktualisierung vor der automatischen HS Aktualisierung manuell aktualisiert werden die Signale schon aktualisiert und dann nicht mehr bei der zeitbedingten Aktualisierung protokolliert bzw. geroutet.
Kann es sein, dass ich das unbewusst mache, indem ich jeden Morgen vor dem Open Investox schliesse und wieder öffne?

Vielen Dank und

beste Grüsse

Roger