Samstag, 21. September 2019, 11:56 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: INVESTOX-Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Martin

unregistriert

1

Mittwoch, 8. Juli 2009, 20:07

Order wird verspätet ausgegeben

Hallo zusammen,

ich hatte heute bei meinem automatisierten Handelssystem das Problem, dass eine Order ca. 15 Minuten verspätet umgesetzt wurde.

Lt. Handelssystem sollte die Order um 17:25 Uhr durchgeführt werden. Im Orderbuch von Investox ist diese auch mit 17:25:05 Uhr registriert. Die Order wurde allerdings erst um 17:39 Uhr bei IB durchgeführt. Im IV Orderbuch ist auch um 17:39 Uhr eine Aktualisierung der Sicherheitsstopps aufgeführt. Meine eMailbenachrichtigung habe ich auch um 17:39 Uhr erhalten.

Vor ein paar Tagen hatte ich schon mal das ähnliche Problem, allerdings waren es dort nur 3 Minuten.

Bei mir stellt sich nun die Frage, woher die Verzögerung kommt. Hat Investox die Order zu spät an IB gesendet oder hat IB die Order so spät ausgeführt.

Hat jemand eine Idee, wie ich feststellen kann, wann die Order zu IB gesendet wurde?

Grüße Martin

Frieder

unregistriert

2

Mittwoch, 8. Juli 2009, 20:17

Hallo Martin,

den Eingang der Order kannst du ja in der TWS unter "Ansicht"/"Ausführungen" erkennen, incl. Sekunden-Angabe. Ich habe mal eine Zeitlang alle Zeit-Angaben in Excel dokumentiert, angefangen von den Zeiten in den Order-Details des ORM, den Zeiten des Orderbuchs bis zu den Ausführungszeiten der TWS. Die Verzögerungen von der Orderentstehung in IV bis zur Ausführung in der TWS liegen in ca.90% der Fälle unter 10 sec, in seltenen Fällen bis zu 30 sec, abhängig von der Tick-Dichte und Anzahl der parallel laufenden HSe...

Delays wie du sie berichtest sind mir noch nie untergekommen.

Ich tippe auf Diskrepanzen zwischen Orderentstehung und eingestellter Aktualisierung im HS.

Martin

unregistriert

3

Mittwoch, 8. Juli 2009, 20:33

Hallo Frieder,

Danke für den Hinweis. In der TWS unter "Ausführungen" sehe ich aber nur, wann die Order tatsächlich ausgeführt wurde nicht aber wann die Order in der TWS aufgegeben wurde.

Ich handle das HS bereits seit ca. 1,5 Monate real und ca. 2 Monate im Papertrading. Da hatte ich die Zeiten wie sie dir auch bekannt sind. Am Handelssystem dürfte eigentlich nichts sein, da wie gesagt die Orders sonst immer korrekt ausgegeben werden.

Gestern Abend habe ich jedoch ein Update auf IV 5.5.6 durchgeführt, aber daran dürfte es wohl nicht liegen.


Grüße Martin

Lenzelott Männlich

Erleuchteter

Registrierungsdatum: 30. Dezember 2002

Beiträge: 2 928

Wohnort: Giessen

4

Donnerstag, 9. Juli 2009, 13:22

Hallo Martin,

hast Du die Protokolldateien in Investox schon mal "durchforstet" ;
zu finden unter "Order / Einstellungen/Protokolle".

Manchmal bringt das auch Erleuchtung.
If you think it´s expensive to hire a professional, wait until you hire an amateur.

Martin

unregistriert

5

Sonntag, 12. Juli 2009, 14:48

Hallo Lenzelott,

da habe ich auch schon nachgesehen aber mit dem Protokoll komme ich nicht ganz klar. Es ist meiner Meinung nach nicht eindeutig, ob Order Plus die Order rechtzeitig an die TWS gesendet hat oder die TWS die Order zu spät ausgegeben hat.

Im Protokoll steht in Aufgabedatum und Aktuelle Zeit 17:25 Uhr, Aktion "Short", Ordertyp "Bestens (at market)", der Orderstatus steht auf "unbearbeitet", ausgeführt am steht "K/A".

Um 17:39 Uhr kommt nochmals die gleiche Meldung, Aufgabedatum 17:25 Uhr und Aktuelle Zeit 17:39 Uhr, der Orderstatus steht dann auf "Aktiv".

Und danach steht um 17:39Uhr nochmals die Order drin mit Aufgabedatum 17:25 Uhr und aktuelle Zeit 17:39 Uhr, im Status steht nun "Ausgeführt" und in "ausgeführt am" steht dann auch die Ausführungszeit von "17:39 Uhr" drin.

Bedeutet dies, dass das Signal von IV korrekt um 17:25 Uhr ausgegeben wurde aber von der TWS nicht korrekt bearbeitet und erst um 17:39 Uhr weitergeleitet wurde?

Gruß Martin

Lenzelott Männlich

Erleuchteter

Registrierungsdatum: 30. Dezember 2002

Beiträge: 2 928

Wohnort: Giessen

6

Sonntag, 12. Juli 2009, 18:11

Was steht denn in der Fehlerprotokolldatei und der Statusdatei?
Wenn eine Order den Status unbearbeitet hat, muss ja in den Dateien etwas dazu vermerkt stehen.

Ich würde einfach mal sämtliche Protokoll Dateien an Herrn Knöpfel mailen wenn Du damit nicht klar kommst,
der wird Dir bestimmt weiterhelfen wann was genau passiert oder schiefgegangen ist.
If you think it´s expensive to hire a professional, wait until you hire an amateur.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Lenzelott« (12. Juli 2009, 23:27)


Ähnliche Themen