Samstag, 22. September 2018, 12:02 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: INVESTOX-Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

VBSdummy

Benutzer

Registrierungsdatum: 9. November 2008

Beiträge: 74

1

Mittwoch, 30. Dezember 2009, 17:48

IB Backfill

Hallo,

ich habe folgendes Problem:

Der manuelle IB Backfill (Datenpflege), wo man einstellen kann, ab wann man die Kurse nachladen möchte funktioniert bei mir nicht mehr?


Auf einem anderen Rechner funktioniert der Backfill mit den gleichen Programmversionen problemlos.
Der automatische Backfill funktioniert.
Wenn ich den manuellen Backfill starte und das Startdatum eingebe kommt für 1 sec das Backfill Fenster und verschwindet dann sofort wieder. Ein Problem mit der API?

Ich scheine irgendetwas verändert zu haben, nur was? Vielleicht weiß jemand Rat!?

VBS

Lenzelott Männlich

Erleuchteter

Registrierungsdatum: 30. Dezember 2002

Beiträge: 2 900

Wohnort: Giessen

2

Mittwoch, 30. Dezember 2009, 19:25

Ich hatte neulich mal das Problem, dass ich die Connectiongrenze der TWS erreicht hatte.
Der backfill von RTT baut eine 2. Connection zur TWS auf und wenn zu diesem zeitpunkt bereits durch mehrere RTT´s / Investox Instanzen die Grenze schon erreicht war, geht´s in die Hose.
If you think it´s expensive to hire a professional, wait until you hire an amateur.

VBSdummy

Benutzer

Registrierungsdatum: 9. November 2008

Beiträge: 74

3

Donnerstag, 31. Dezember 2009, 10:32

Ich zeichne lediglich 20 Titel auf. Aber trotzdem vielen Dank für den Hinweis auf eine mögliche Fehlerquelle. Ich werde mal die API neu installieren.

Bernd

Erleuchteter

Registrierungsdatum: 5. Juni 2005

Beiträge: 3 864

Wohnort: Iringsweg

4

Donnerstag, 31. Dezember 2009, 12:11

Ich zeichne lediglich 20 Titel auf.

Es kommt auf die Gesamtzzahl an, nicht nur, was Du aufzeichnest! Du musst addieren, also RTT Titel + Backfill Titel + was in der TWS sonst noch angezeigt wird (TWS Ticker, Booktrader, Charts). Wenn's an der Grenze ist, kommt das zuletzt gestartete zu spät - naturgemäss meistens der RTT Backfill und im Zweifel der von Hand gestartete.

Davon abgesehen, geht der von Hand gestartete auch bei mir zu manchen Zeiten nicht. Stunde später geht's dann wieder, hängt vielleicht auch mit der Serverauslastung bei IB zusammen, kannst die Mädels ja mal anrufen und fragen. Feedback hier im Forum wäre danach schön.
Gruss
Bernd

-----------------------------------------------
http://www.13quants.ch

sten

Erleuchteter

Registrierungsdatum: 6. September 2002

Beiträge: 2 879

5

Donnerstag, 31. Dezember 2009, 14:27

Hallo,

Zitat

Davon abgesehen, geht der von Hand gestartete auch bei mir zu manchen Zeiten nicht. Stunde später geht's dann wieder, ...


Ist bei mir auch so, z.B. 15:30Uhr US-Aktienkurse nachladen funktioniert häufig mal nicht. Am besten auf weniger hektische Börsenzeiten ausweichen für den Backfill. Konnte mich in letzter Zeit auch häufig mal am Wochenende bei IB einloggen.

Viele Grüße
Torsten

Lenzelott Männlich

Erleuchteter

Registrierungsdatum: 30. Dezember 2002

Beiträge: 2 900

Wohnort: Giessen

6

Sonntag, 3. Januar 2010, 15:36

Ich glaube da hat jemand meinen post nicht richtig gelesen.

Mein Problem bestand nicht in der TWS üblichen Tickergrenze von 100 Symbolen (welches auch zu Fehlern führen kann) sondern darin, dass die Connectionanzahl der TWS begrenz ist (7 oder 8 weiß nicht mehr genau) und RTT für einen Backfill eine 2. Connection aufbaut.
Hat man nun die Connectionanzahl der TWS mit diversen Instanzen und RTT erreicht, kann kein Backfill mehr stattfinden, da die TWS keine neue Verbindung zuläßt.
If you think it´s expensive to hire a professional, wait until you hire an amateur.

VBSdummy

Benutzer

Registrierungsdatum: 9. November 2008

Beiträge: 74

7

Sonntag, 3. Januar 2010, 17:17

Vielen Dank für den Hinweis; ich habe das in der Tat nicht richtig gelesen.

Aber auch die Anzahl der Connections dürfte nicht das Problem sein; ich habe die Anzahl der connections mit unterschiedlichen Client-Ids probiert - das selbe Ergebnis.

Ich arbeite gelegentlich mit so einem tool - wie hier beschrieben:
http://ibcollector.com/

Vielleicht habe ich damit etwas verstellt; ich glaube es nur nicht. Wie gesagt, auf einem anderen Rechner mit den selben Versionen funktioniert der manuelle backfill.

Auch die Neuinstallation der letzen API und RTT-Version hat keine Veränderung gebracht.

Auch habe ich den JTS Ordner vom anderen Rechner auf den Problem-Rechner rüber kopiert....

Langsam gehen mir die Ideen aus ... ;-)

VBS