Donnerstag, 20. September 2018, 09:52 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: INVESTOX-Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Arinest

unregistriert

1

Freitag, 15. Februar 2013, 12:43

ständig "Exit-Order wurde nicht aufgegeben" im Investox-Logbuch

Hallo,

ich komm irgendwie nicht zu Potte. Die Papertrades über IB scheinen so in Ordnung, aber ständig unmittelbar nachdem die Position geschlossen wird kommt diese Meldung. Ursache laut Logbuch: "Es besteht keine Position, für die ein Exit durchgeführt werden kann." Das ist mir klar, denn die Position wurde ja wie gesagt gerade geschlossen. Es scheint, als ob da noch ein Exit in den Markt will. Das seltsame ist, ich habe nach dem Entry lediglich Verlust- und GewinnStops am werkeln. Bei der Regel für Exit steht bei mir: 0.

Hat jemand eine Ahnung, woran diese Meldung liegen könnte. Irgendein Fehler muss ja da sein sonst würde sich das Logbuch nicht melden. Gerne geb ich euch auch die Projekt-Datei, damit man sich das mal anschauen kann.

Grüße,
Arinest

Lenzelott Männlich

Erleuchteter

Registrierungsdatum: 30. Dezember 2002

Beiträge: 2 900

Wohnort: Giessen

2

Freitag, 15. Februar 2013, 13:01

Ein Stop der in Investox ausgelöst wird, versucht immer die Position via Ordermodul bei IB zu schließen.
Wenn Du den Stop allerdings direkt im Depot angepaßt hast (Ordermodul mit Berechnungsvariable, bzw. im Stop fortlaufend anpassen aktiviert ist) , wurde die Position schon durch den Stop bei IB geschlossen.
Wenn nun der Fill von IB an Investox zurückgemeldet wurde befindet sich nix mehr im Depot.
Der Stop aus Investox will die Position schließen, findet nix mehr im Depot, daher die Fehlermeldung.
If you think it´s expensive to hire a professional, wait until you hire an amateur.

Arinest

unregistriert

3

Freitag, 15. Februar 2013, 14:23

Hallo Lenzelott,

vielen Dank für die schnelle Antwort. Ich glaube zu verstehen wie es abläuft.

Wenn Du den Stop allerdings direkt im Depot angepaßt hast (Ordermodul mit Berechnungsvariable, bzw. im Stop fortlaufend anpassen aktiviert ist) , wurde die Position schon durch den Stop bei IB geschlossen.

Tut mir leid. Das versteh ich nicht ganz. Wo genau ist das zu aktivieren. Ich finds nicht.

Bei mir ist es so: Ich habe im Ordermodul 2 Sicherheitsstops: Gewinn Long: 5 Punkte, Verlust Long: 5 Punkte. Anzupassen an die zuletzt gefillte Order.
Unter den Testbedingungen habe ich 2 Standard-Stops: Intraday-Verlust Long: 5 Punkte, Intraday-Gewinn Long: 5 Punkte + 1 Sofort-Stop: 5 Punkte.
Muss ich jetzt mit dieser Fehlermeldung leben oder gibt es einen anderen Weg?

Arinest

unregistriert

4

Montag, 18. Februar 2013, 23:08

Hallo, ich nochmal.
Ich habe heute die unter "Ordereinstellungen bearbeiten" angegebenen Sicherheitsstops (Verlust Long: 5 Punkte, Gewinn Long: 5 Punkte) ausgeschaltet und alles lief wie gewünscht. Keine Meldungen mehr vom Investox-Logbuch. Das war auch zu erwarten, denn nun gibt es ja auch nur noch den Stop von Investox. Sobald ich die Stops der automatischen Orderaufgabe wieder anschalte, werden diese zuerst ausgelöst, Investox findet keine Position zum schließen und gibt die Fehlermeldung aus. So wie es Lenzelott beschrieben hatte.

Da ich aber auf keinen Fall ohne die Sicherheitsstops handeln werde, gleichzeitig aber auch das Investox-HS und das Realtime-Trading synchron arbeiten sollen, muss ich wohl mit dieser Fehlermeldung leben. Das wäre nicht so schön, denn eine Fehlermeldung setzt bei mir ein Gefühl des Unbehagens aus. Ebenso könnte ich in Zukunft die Meldungen des Logbuchs nicht mehr so genau anschauen, denn es ja bloß diese lästigen, und eine "richtige" Meldung übersehen. Alles ein bischen suboptimal. Deshalb nochmal die Frage: Gibt es einen anderen Weg, diese Fehlermeldung zu vermeiden?

Vielen Dank für eure Hilfe,
Arinest

Lenzelott Männlich

Erleuchteter

Registrierungsdatum: 30. Dezember 2002

Beiträge: 2 900

Wohnort: Giessen

5

Dienstag, 19. Februar 2013, 01:31

Gibt es einen anderen Weg, diese Fehlermeldung zu vermeiden?


Nein
If you think it´s expensive to hire a professional, wait until you hire an amateur.

Investox

Administrator

Registrierungsdatum: 31. August 2002

Beiträge: 5 566

6

Dienstag, 19. Februar 2013, 08:30

Hallo,

wenn die Meldung in der aktuellen Form Unbehagen auslöst, könnten wir sie auch umformulieren, etwa in "Exit-Order wurde nicht benötigt"?

Viele Grüße
Andreas Knöpfel

Arinest

unregistriert

7

Dienstag, 19. Februar 2013, 11:53

Danke für die Antworten.

wenn die Meldung in der aktuellen Form Unbehagen auslöst, könnten wir sie auch umformulieren, etwa in "Exit-Order wurde nicht benötigt"?


Da es bestimmt viele Gründe für "Exit-Order wurde nicht aufgegeben" gibt, wäre eine genauere Differenzierung gar nicht so schlecht. Ich wüsste dann sofort den Grund für die Meldung und wäre sofort beruhigt. :rolleyes:

Gruß,
Arinest