Donnerstag, 20. September 2018, 17:32 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: INVESTOX-Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Wiwu Weiblich

Meister

Registrierungsdatum: 4. September 2002

Beiträge: 1 618

Wohnort: Neuenhagen b. Berlin

1

Montag, 15. Mai 2017, 14:58

RTT 3.4.0 , API und TWS...

So - heute trifft es mich:

Nach dem Update von RTT, API und TWS kommt keine Verbindung zwischen RTT und der TWS mehr zustande.

Folgendes ist installiert:

-RTT Version 3.4.0
-XL 7.4.2
-TWS 963.3 (stable) vom 09.05.2017 - gleiches Verhalten tritt aber auch auf mit Version 964.1 (latest) vom 09.05.2017
-Gateway 963
-API 9.72.18.0

Redistributables:




-Vertrauenswürdige IP in TWS API-Einstellungen ist gesetzt - 127.0.0.1
- Syswow64 - TWSSocketClient.dll - Version ist geprüft 9.72.18
- TWS.ocx - ist nicht auffindbar unter c: JTS oder über die Suche an irgendeiner anderen Stelle im System - es erscheint aber auch keine der üblichen TWS.ocx Fehlermeldungen

Hat jemand eine Idee zur Abhilfe bzw. eine funktionierende Konstellation aus API/TWS-Version ??? für RTT 3.4.0 / XL 7.4.2. ?

Anbei noch die RTT-Fehlermeldungen:







Danke und beste Grüße.
Viele Grüße von Anke

http://www.ascunia.de

Registrierungsdatum: 17. September 2002

Beiträge: 173

2

Montag, 15. Mai 2017, 16:55

RTT, API und TWS

Hallo Anke!

IB hat die API verändert. Wurde neu in >C< geschrieben. TWS ocx und SocketClient wird wohl nicht mehr benötigt.
Abhilfe des beschriebenen Problems hat ein Häkchen in den API-Settings gebracht.
>Allow connections from localhost only< ankreuzen, hat bei mir zum Erfolg geführt.
»vice versa« hat folgendes Bild angehängt:
  • API Settings.PNG
Grüsse

vice versa

Registrierungsdatum: 17. September 2002

Beiträge: 173

3

Montag, 15. Mai 2017, 17:00

RTT, API und TWS

Hallo Anke!

RTT 3.4.0 läuft nur mit API 973. Keine tiefere Version!
Grüsse

vice versa

Wiwu Weiblich

Meister

Registrierungsdatum: 4. September 2002

Beiträge: 1 618

Wohnort: Neuenhagen b. Berlin

4

Montag, 15. Mai 2017, 18:10

Hallo vice versa,

hab vielen lieben Dank für diese Informationen.
Mit der API 973 und dem Häkchen in der TWS funktioniert hier jetzt auch alles.

Ich hatte mich an den Versions-Infos auf der Investox-Webseite orientiert.

Beste Grüße und einen schönen Abend von

Anke

Investox

Administrator

Registrierungsdatum: 31. August 2002

Beiträge: 5 566

5

Montag, 15. Mai 2017, 19:45

Hallo,

bei uns läuft es mit der API 9.7.2. Es lag also wohl eher am Häkchen bezüglich der erlaubten Verbindung. Dieses muss gesetzt sein oder es muss explizit in Investox/RTT die IP-Adresse angegeben werden.

Eine TWS.ocx wird in der Tat nicht mehr verwendet, die TWSSocketClient.dll ist aber nach wie vor relevant.

Viele Grüße
Andreas Knöpfel

Vuego

Meister

Registrierungsdatum: 30. August 2002

Beiträge: 982

6

Montag, 15. Mai 2017, 20:38

Zitat

es muss explizit in Investox/RTT die IP-Adresse angegeben werden.

kann ich bestätigen

TWS 9.63
API 9.72
INV 7.42
RTT 3.40

- Lokale IP erlaubt
- Haken "allow connections from localhost only" nicht gesetzt (enablen kann ja demnach nicht schaden)

Neon

Benutzer

Registrierungsdatum: 12. Mai 2012

Beiträge: 22

7

Samstag, 10. Juni 2017, 22:14

Hallo zusammen,

ich habe heute ebenfalls auf die jeweils neuen Versionen upgegradet.

TWS 9.63
API 9.72
Gateway 963
RTT 3.40
----------------
INV 6.9.11

Dank der obigen Hinweise hat soweit auch alles funktioniert (Stichwort: "Nur Verbindungen vom lokalen Host zulassen").
Ich nutze grundsätzlich das Gateway. Zwischen diesem und RTT kann wie gewünscht eine entsprechende Verbindung hergestellt werden.

Leider tritt aber beim Verbinden von INV mit IB der Fehler Nr. 5 auf (Die Verbindung zur TWS konnte nicht hergestellt werden (Fehler Nr. 5). Prüfen Sie bitte, ob die TWS sowie die API von IB korrekt installiert sind.).
Da die Verbindung zwischen Gateway und RTT reibungslos funktioniert, gehe ich eigentlich davon aus, dass die Installationen korrekt erfolgt sind.
Die Port-Einstellungen in INV sind identisch zu denen im Gateway (API-Einstellungen) und in RTT.

Welche Ursache könnte das Auftreten des Fehlers Nr. 5 haben?
Und wie lässt sich die Verbindung zwischen INV und dem Gateway wieder herstellen?

Vielen Dank im Voraus für eure Hilfe und viele Grüße
Neon

Neon

Benutzer

Registrierungsdatum: 12. Mai 2012

Beiträge: 22

8

Sonntag, 11. Juni 2017, 12:06

Hallo zusammen,

das Upgrade von INV auf die Version 6.9.15 war letztlich entscheidend.
Jetzt funktioniert auch wieder die Verbindung von INV zum Gateway.

Viele Grüße
Neon

Neon

Benutzer

Registrierungsdatum: 12. Mai 2012

Beiträge: 22

9

Sonntag, 25. Juni 2017, 11:00

Hallo zusammen,

die API-Version 9.7.2 funktionierte letztlich doch nicht mit meiner INV-Version 6.9.15. Nach kurzer Zeit der erfolgreichen Verbindung mit dem Gateway erhielt ich die Info: "KSEIBUeberwachung hat ein Problem festgestellt und muss beendet werden".

Auf folgenden Versionen bin ich nun stabil unterwegs.

TWS 9.63
API 9.71
Gateway 963
RTT 3.36 (Vielen Dank an Frau Beyer für die zur Verfügung Stellung dieser Version)
----------------
INV 6.9.15

Viele Grüße
Neon

felixhn Männlich

Benutzer

Registrierungsdatum: 1. März 2004

Beiträge: 60

Wohnort: Kiel

10

Sonntag, 2. Juli 2017, 19:26

Hallo,

mein Problem nach Update auf die neueste RTT-Version und Aktualisierung von API und Gateway ist m.E. nicht das "übliche":

RTT gibt aus "Fehler bei Kurspflege aufgetreten. Invalid procedure call or argument."

Datenpflege ist daher nicht möglich.

Versionen:
RTT 3.4.0
Gateway Build 966.1a, Jun 27, 2017 2:57:22 PM
API 9.73.03

Hat jemand eine Idee?
Viele Grüße,
Felix

Investox

Administrator

Registrierungsdatum: 31. August 2002

Beiträge: 5 566

11

Montag, 3. Juli 2017, 11:53

Hallo,

die aktuellen Versionen von Investox/RTT benötigen die API 9.7.2, nicht 9.7.3.

Also:

INV 7.42
RTT 3.40

-> IB API 9.72

Viele Grüße
Andreas Knöpfel

felixhn Männlich

Benutzer

Registrierungsdatum: 1. März 2004

Beiträge: 60

Wohnort: Kiel

12

Montag, 3. Juli 2017, 19:40

Hallo Herr Knöpfel,

ja, wahrscheinlich war die Problemstellung zu einfach... das war's auch schon!

Vielen Dank!

Viele Grüße,
Felix