Samstag, 20. April 2024, 21:38 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: INVESTOX-Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Registrierungsdatum: 4. September 2007

Beiträge: 311

Wohnort: Stuttgart

121

Montag, 3. März 2008, 10:54

Hallo,

funktioniert bei euch jetzt eigentlich der FWD-Indikator unter Inv515?

Jetzt habe ich noch eine Verständnisfrage: Der normale Weka-Indi zeigt ja lediglich das Signal für eine Periode an. Deshalb verstehe ich noch nicht, wofür dieser eigentlich da ist. Vor allem da Signale ja kommen und gehen weil er ja in jeder neuen Periode die Berechnung neu durchführt. Und ist der FWD-Indikator nur zum testen, oder ist dieser Indi für reelle Backtests gedacht? Das habe ich noch nicht so ganz verstanden.

Gruß Arend
Grüße aus dem Schwabenland
Arend

MartinP Männlich

Meister

Registrierungsdatum: 13. März 2007

Beiträge: 690

Wohnort: Köln

122

Montag, 3. März 2008, 15:15

Hallo,

ob der Indi für 5.1.5 bei Euch funktioniert würde mich auch interessieren.

Der Fwd-Indi kann natürlich auch für den realen Einsatz verwendet werden. Wenn man die Wiederholungen auf 1 setzt wird halt genau ein SVM aktuell trainiert. Damit kann er auch für den realen Einsatz verwendet werden. Die Performance sollte bei beiden Indis gleich sein.

Viele Grüße

Martin

Terminator3

unregistriert

123

Montag, 3. März 2008, 15:50

Spread: Ich handele immer einen Lot, 10000, und hab die Ein und Austieg Kosten auf $.5 gesetzt.
Das stimmt zwa nicht ganz, aber es reicht ja zu sehen das die KK im Eimer ist.
Mit 60min hab ich noch keine gute KK erzeugt.
Die Einstellungen sind in der txt file.
WekaIndis.weka ist default.


hmm..

ich sehe bei dir ein system mit und ohne spreads

wie gibts du den spread denn in den testeinstellungen an?

ich benutze immer eine slippage von 0,00009
und punktetest

aber eine komprimierung von 5min ist denke ich zu knapp, versuch es mal mit min 60min...

welche svm-einstellung benutzt du denn?
den feed-fwd indi? wenn ja mit welchen parametern?
und wie sieht deine wekaindi-datei aus? wegen den inputs?


ich experimentier mit svm´s auch schon seit tagen, ahb einige systeme mit KK-Analyse entwickelt
welche auch noch oben zeigen, aber r nicht jeder titel klappt mit den gewählten einstellungen,
ich weiss nicht was den unterscchied ausmacht..
am kurverlauf liegt es glaube ich nicht,
ich habe zwei titel mit ähnlichen kursverläufen gehabt die beide nach unten zeigten,

und as doofe ist ja man weiss im voraus ja nicht wie der kurs verläuft..

mit dem aroon hab ich auch schon versuucht trandphasen rauszufilternr, aber auch da gilt :

manchmal gehts besser, andermal zeigt die KK durch aroon noch unten...

Hans-Jürgen Männlich

Administrator

Registrierungsdatum: 10. Juli 2002

Beiträge: 1 712

124

Montag, 3. März 2008, 17:03

ob der Indi für 5.1.5 bei Euch funktioniert würde mich auch interessieren.


Hallo Martin,

hat es denn ein Update gegeben?
Viele Grüße,
Hans-Jürgen

Registrierungsdatum: 4. September 2007

Beiträge: 311

Wohnort: Stuttgart

125

Montag, 3. März 2008, 17:22

Hallo,

es gab so viel ich weis kein Update. Ich fragte halt da sich auser @ulukai keiner gemeldet hat, ob er funktioniert oder nicht. Also bei mir kommt auch die selbe Fehlermeldung wie bei ulukai.

Danke Martin für die Antwort. Aber mit dem FWD-Indi gibt es doch auch die Möglichkeit ihn über einen bestimmten Zeitraum zu testen und dann so einzufrieren, also ohne das er sich dann wieder neu berechnet. So wie bei NN`s. Denn ich muss ja sehen ob und wie lange er Robust ist. Oder verstehe ich da etwas völlig falsch.

Gruß Arend
Grüße aus dem Schwabenland
Arend

Chemie262

unregistriert

126

Montag, 3. März 2008, 17:50

Hallo Martin,
der WekaIndikator arbeitet mit 5.1.5
Aber der WekaFwdIndikator liefert kein Ergebnis und es fehlen im Indikator auch die zusätzlichen Parameter, die Du angesprochen hast. Er sieht genauso aus wie der Indi für 5.1.4
Tschüß,
Herbert

ulukai

unregistriert

127

Montag, 3. März 2008, 18:54

@terminator3

beim RBF-kernel hast du den Komplexitätswert auf 1 . Ich bin zwar kein SVM-Experte , aber ich denke das ist viel zu wenig.

Versuch mal den c Wert auf min 50 zu erhöhen und evtl. die trainingszeiten zu verlängern,

aber ich denke den größten einfluss hat die wekaindis-datei und die wahl des Kernels...

Alex73 Männlich

Profi

Registrierungsdatum: 9. Oktober 2007

Beiträge: 211

Wohnort: Niederbayern

128

Montag, 3. März 2008, 19:42

@ ulukai,

ich berechne zB. bei den Währungen die netto erwirtschafteten Pips.
Dann kann ich die Ergebnisse unter den verschiedenen Währungen direkt vergleichen.
Die Slpippage wird auf einen halben Spread gesetzt. Meist 3 oder 4 Pips /2.

z.B. EUR/USD

Punkte testen
Initial Margin: 1 E
Wert pro Punkt: 10000 E
Gewinn-/Verlustberechnung verwendet High/Low-Kurse.
Entry-Gebühren: 0 E
Exit-Gebühren: 0 E
Slippage: 1,5 E

z.B. USD/JPY

Initial Margin: 1 E
Wert pro Punkt: 100 E
Gewinn-/Verlustberechnung verwendet High/Low-Kurse.
Entry-Gebühren: 0 E
Exit-Gebühren: 0 E
Slippage: 2 E

MartinP Männlich

Meister

Registrierungsdatum: 13. März 2007

Beiträge: 690

Wohnort: Köln

129

Dienstag, 4. März 2008, 16:28

Hallo zusammen,

ich hab auf meinem Betriebssystem gerade den Update auf 5.1.5 durchgeführt. Die Installation des Weka-Indikators hat bis auf eine kleine Unachtsamkeit meinerseits geklappt.

Das Archiv mit den neuen DLLs enthält nicht die für die Registrierung erforderlichen gac....

Da ich das Archiv jedoch - entgegen meiner eigenen Anleitung - in ein neues Verzeichnis entpackt habe klappte die Installation zuerst nicht.

Und ihr könnt leicht feststellen ob ihr die richtige Definition für die Indikatoren in Investox habt. Beim WekaFwdIndikator ist unter Algorithmus nun eine recht lange Liste an unterschiedlichen Berechnungsalgorithmen aus Weka wählbar.

Viele Grüße

Martin

Registrierungsdatum: 4. September 2007

Beiträge: 311

Wohnort: Stuttgart

130

Dienstag, 4. März 2008, 18:07

Hallo Martin,

ich bin glaub blind. Wo finde ich eigentlich die "wekaindis.weka"-Datei. Denn ich habe noch eine alte Weka-Datei drin. Das könnte bei mir der Fehler sein. Auf Deiner Wiki-Seite finde ich sie nicht.

Gruß Arend

Nachtrag. Habe jetzt nochmal die Zip-Datei vom ersten Posting dieses Threads installiert, dann die 5.14 Datei von Deiner Wiki Seite und zum Schluss die 5.15 Datei. Der normale Indi funktioniert tadellos aber beim FWD kommt immer Fehler Nr. 6 und unter Algorithmus kann ich nur SVM auswählen. Was mache ich falsch?
Grüße aus dem Schwabenland
Arend

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »trader-hawk« (4. März 2008, 18:24)


MartinP Männlich

Meister

Registrierungsdatum: 13. März 2007

Beiträge: 690

Wohnort: Köln

131

Dienstag, 4. März 2008, 18:26

Hallo Arend,

im Wiki habe ich auf der Seite mit den DLL-Indikatoren ein Beispiel für die Datei wekaIndis.weka aufgenommen.

Viel Spaß

Martin

Registrierungsdatum: 4. September 2007

Beiträge: 311

Wohnort: Stuttgart

132

Dienstag, 4. März 2008, 18:39

Hallo Martin,

danke für die schnelle Bereitstellung eines Beispieles auf Deiner Wiki. :thumbsup:

Aber bei mir kommt der Fehler immer noch und ich kann auch nur SVM auswählen. Funktioniert er denn unter Inv. 5.15 bei allen anderen? Und wieso geht er bei Dir Martin und nicht bei mir ;(

Gruß Arend
Grüße aus dem Schwabenland
Arend

MartinP Männlich

Meister

Registrierungsdatum: 13. März 2007

Beiträge: 690

Wohnort: Köln

133

Dienstag, 4. März 2008, 18:43

Hallo Arend,

lade dir bitte den INN-File neu ("http://www.agile-germany.de/IVKDll/WekaDLL_515.Inn" kopiert aus meinem Wiki).
Lösche die beiden alten Indis in deinem Investox (WekaIndikator und WekaFwdIndikator) und lade sie dann erneut mit dem INN.

Dann sollte es klappen.

Grüße

Martin

Registrierungsdatum: 4. September 2007

Beiträge: 311

Wohnort: Stuttgart

134

Dienstag, 4. März 2008, 19:02

Juhuu Martin es funktioniert.

Dankeschön.

Jetzt muss ich erst mal mit ihm ein wenig experimentieren und ihn verstehen lernen.

Gruß Arend
Grüße aus dem Schwabenland
Arend

Terminator3

unregistriert

135

Donnerstag, 6. März 2008, 00:46

Tobias,

koennten Sie so freundlich seihen um Ihre Inputs/Enter regeln mit uns zu teilen?
Was genau meinten Sie mit "dynamisieren"? Wie haben Sie dass in Investox gemacht?
Sind die ROC's einfach von den Close Preis vom verwendeten Titel? Oder auch noch Intermarket Beziehungen oder so?


Vielen Dank!
Tim

@Chemie : Das hat was mit den EInstiegen im ORM zu tun. Schau mal, ob es richtig einsteigt - und der EInstieg realistisch ist.

HIer meine KK vom Eurostoxx50 :
78,5% Trefferquote ab 1.1.2007
An den Inputs habe ich nichts Spektakuläres geändert.
Hauptsächlich einige Roc´s und das wesentliche ist eine dynamische Grenze in den Enter Bedingungen, also nicht nur SVM>0, sondern dynamisieren !

ulukai

unregistriert

136

Donnerstag, 6. März 2008, 01:21

was genau meint man denn in dem fall mit dynamisieren?

also nicht svm>0 , sodnern was?

wenn es nicht 0 ist, welche zahl dann, und wenn diese zahl adaptiv ist, wovon ist sie abhäöngig?

Terminator3

unregistriert

137

Donnerstag, 6. März 2008, 06:22

Ich glaube ich muss echt ins Bett..
Um so kleiner mein Intraday-Gewinn Stop um so mehr Profit und kleineren DD kriege ich.
Stimmt hier ergentwas nicht? Oder wieso ist das so?
Das System ist ein Forex System mit $1000 Kapital, Hebel von 10, spread noch nicht drinne aber ich kriege genug Profit/Trade (.24%) um den Spread zu bezahlen..899 Trades, davon 85% profitable, nur wegen einen Stop..
Hier im Screenshot steht er glaubich selbst auf .005 Punkte...


Kann mir bitte einer sagen was hier nicht stimmt? Das muss wohl der Backtest sein..

Fritz

unregistriert

138

Donnerstag, 6. März 2008, 09:01

Hallo,

was genau meint man denn in dem fall mit dynamisieren?

also nicht svm>0 , sodnern was?

wenn es nicht 0 ist, welche zahl dann, und wenn diese zahl adaptiv ist, wovon ist sie abhäöngig?


ich bin zwar nicht angesprochen, glaube aber zu verstehen, was gemeint ist.
Es gibt in Investox seit uralten Zeiten den Indikator DynGrenze. Damit kann man z.B. einen Indikator oder den Output eines NN oder eine Zeitreihe dahingehend auswerten, das man die Ausprägung der Werte in einer einstellbaren Periodenzahl der Vergangenheit auswertet und sich dadurch eine dynamisch verändernde Grenze einstellt. Bei einer Einstellung von zB. 50%
liegen jeweils die Hälfte der Werte über bzw. unter dieser Grenze, die dann eben nicht 0 sondern mal größer oder auch kleiner 0 sein kann.

Viele Grüße Fritz

Registrierungsdatum: 30. August 2002

Beiträge: 8 155

Wohnort: Trade-Planet

139

Donnerstag, 6. März 2008, 09:58

Hallo Tim,

was anderes: Wenn das System ab NOV 2006 Out of Sample ist, sollte man das Ganze noch einmal checken, den anhand der Korrelation KK-Zeitreihe kann man ein klare Überoptimierung erkennen! Das würde bedeuten, dass das System lediglich kopiert und nicht "generalisiert"- wenn man das bei SVM überhaupt so sagen kann...
Happy Trading

ulukai

unregistriert

140

Donnerstag, 6. März 2008, 10:51

@fritz

jo, dyn granzwert hab ich gefunden,

merkwrüdig, habe ich vorher noch nie gesehen,

nun gut, aber wie wende ich ihn an?

es gibt da wieder 3-4 variablen und ich weiss genausowenig wie bei den svm´s welche werte ich da ei ntragen soll,

und da man svm´s mit ga´s ja nicht optimieren kann, weiss ich nun wieder nicht weiter

oder gibt es eine generelle einstellung die ganz gut klappt??