Samstag, 24. Februar 2024, 04:46 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: INVESTOX-Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Rainer

Besucher

Registrierungsdatum: 30. November 2022

Beiträge: 10

1

Montag, 5. Dezember 2022, 10:06

Zweite von der Herkunft nicht nachvollziehbare Exit-Stop Order

Hallo,

ich möchte in mein System ein Exit-Stop einbauen und dies funktioniert für die Optimierung soweit auch. Man kann den Verlauf des Stops sehen und alles passt.
Sobald ich jedoch in den Handel gehe, wird der Exit-Stop nicht zum Basiswert eingestellt, sondern zum zuletzt gehandelten Marktpreis. Löst also die nächste Kerze einen Exit-Stop aus, wird der Stop auch sofort eingestellt allerdings zum Open der Kerze.
Das Signalprotokoll zeigt die für mich "richtigen" Werte an. Allerdings scheint dieses Signal gar nicht zum Zuge zu kommen, was die folgende Fehlermeldung zeigt:
Die Order wurde nicht aufgegeben, da bereits eine Order in der selben Zeitperiode des Handelssystems in Arbeit ist oder ausgeführt wurde (Order-Einstellung 'Nur ein Signal pro Periode umsetzen').
Im Orderbuch liegt eine andere Exit-Stop Order, die genau eine Sekunde früher ausgelöst hat.
Ich denke, dass diese Order nur vom Order-Plus-Tool kommen kann, habe auch alle möglichen gesetzten Häkchen mehrfach überprüft, aber ohne Erfolg. Vielleicht sehe ich den Wald mittlerweile vor all den Bäumen nicht, aber ich komme nicht weiter. :baby:

Eure Hilfe wäre mir wirklich sehr willkommen.

Grüße,
Rainer

Rainer

Besucher

Registrierungsdatum: 30. November 2022

Beiträge: 10

2

Dienstag, 6. Dezember 2022, 09:11

Hier zur Verdeutlichung mal das Signalprotokoll mit dem "richtigen" Exit-Long.
Und hier die Order Details:


Die Basis bei Signal bei den Orderdetails (11804,25) ist der erste Kurs der folgenden Kerze. Mir ist unklar, woher diese Basis abgeleitet wird.



Gruß,
Rainer

Bernd

Experte

Registrierungsdatum: 5. Juni 2005

Beiträge: 4 070

Wohnort: Iringsweg

3

Freitag, 9. Dezember 2022, 10:11

Hallo Rainer

Auf welcher Komprimierung läuft denn das HS?

Die Stops, sind das Intrada-Stops oder EOD Stops?

Sind Sofort-Stops im Spiel, oder Tagesstops. Oder ORM Stops?

Viele Faktoren können beteiligt sein; poste am Besten die Ausgabe von Handelssystem -> Informationen. Die Handelsregeln kannst Du ja rauslöschen und durch einen Platzhalter ersetzen (wie z.B.: "gelöscht") .

Lösche aber auch nicht zuviel raus, sonst können die Experten hier auch nicht mehr alle Fehlerquellen erkennen ;)

Der Report enthält leider auch nicht alles, z.B. Deine ORM Settings sind, glaube ich, nicht zu sehen, die müsstest Du schon separat berichten.
Gruss
Bernd

Rainer

Besucher

Registrierungsdatum: 30. November 2022

Beiträge: 10

4

Samstag, 10. Dezember 2022, 11:10

Hallo Bernd,

vielen Dank für deine Bemühungen. Hier schon mal die ORM - Einstellungen.

Gruß
Rainer
»Rainer« hat folgende Bilder angehängt:
  • Aktualisierung.JPG
  • Allgemein.JPG
  • Order.JPG
  • Stops.JPG
  • Überwachung.JPG

Rainer

Besucher

Registrierungsdatum: 30. November 2022

Beiträge: 10

5

Samstag, 10. Dezember 2022, 11:14

....und der Rest...
»Rainer« hat folgende Bilder angehängt:
  • Optionen.JPG
  • Optionen2.JPG

Rainer

Besucher

Registrierungsdatum: 30. November 2022

Beiträge: 10

6

Samstag, 10. Dezember 2022, 12:01

Und hier jetzt der Report. ich habe einiges ge"x"t. Das sollte aber keine Rolle spielen, da es mir lediglich um das Exit geht, welches auch über das ORM wie gewünscht funktioniert.

Grüße
Rainer
»Rainer« hat folgende Datei angehängt:
  • Report.txt (6,41 kB - 542 mal heruntergeladen - zuletzt: 22. Februar 2024, 22:03)

Bernd

Experte

Registrierungsdatum: 5. Juni 2005

Beiträge: 4 070

Wohnort: Iringsweg

7

Sonntag, 11. Dezember 2022, 11:01

Hallo

Dein "Broker "ist Collective2.

Lass' Dein System doch mal auf ein eigenes Konto von Interactivebrokers laufen (kann ja auch ein Papertrading Konto sein), und schau, ob dort alles funktioniert.

Zu collective2, wenn Du also Signale verkaufen möchtest, welcher Kunde soll das Umsetzen bei einem Daytrading-System auf 1 Minuten Basis mit Sekunden-Aktualisierung in unvollendeten Perioden?

Deine Kunden werden über von Collective2 via eMail informiert, und müssten dann Deine Signale subito umsetzen, aber die Preise, die Dein Handelssystem gesehen hat, sind bis dahin doch Meilen (See-Meilen, nicht Land-Meilen!) davon gelaufen.

Es gibt inzwischen wohl auch einen Mechanismus, Autotrader gennannt (ich habe Collective2 die letzten jahre nicht mehr im Blick gehabt, aber finde das hier: https://collective2.com/how-we-calculate…hetical-results

Wie auch immer, das Hin-und Her zwischen den Parteien braucht Zeit.

Deswegen steht in der Doku von Investox ja auch der Hinweis:
"Der Ablauf ist aufgrund der technischen Voraussetzungen der Anbindung und der oft langsamen Antwortzeiten des C2-Servers relativ träge. Bei der Orderaufgabe muss Investox auf die Antwort des C2-Servers warten, um eine Signal-ID zu erhalten. Daher ist die Anbindung für sehr kurzfristige Systeme und/oder sehr viele Titel und Handelssysteme derzeit wohl nicht zu empfehlen."

Ich schätze mal, der Handshake zwischen Investox und Collective2 funktioniert bei Systemen auf Tagesbasis oder höher (Wochenbasis, Quartalsbasis etc.).

Vielleicht kannst Du versuchen, so alle 4h maximal ein Signal zu schicken und sehen, ob das klappt - aber dann musst Du auf Collective2 erst noch Kunden finden, die so häufig und Intraday als Nachahmer (copycat) mit Dir handeln wollen.

Als Referenz schau auch mal diesen Link an: https://collective2.com/api-signal-entry-version-1, unter der Überschrift "Delaying Signal Processing", das ganze hin und her geht über Internet URLs.

Also, da könntest Du auch ein FAX ein Deine Kunden schicken ;)

Intraday-Signale auf unvollendeten 1 Minuten Charts bei Collective2 verkaufen zu wollen, das wirst Du wohl vergessen können.

Solide EOD oder EOW Systeme, damit kannst Du dort aber sicher Punkten.
Gruss
Bernd

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Bernd« (11. Dezember 2022, 11:30)


Rainer

Besucher

Registrierungsdatum: 30. November 2022

Beiträge: 10

8

Montag, 12. Dezember 2022, 10:44

Intraday-Signale auf unvollendeten 1 Minuten Charts bei Collective2 verkaufen zu wollen, das wirst Du wohl vergessen können.
Hallo Bernd. Die Einstellung 1min benutzte ich schon bei der Optimierung, um möglichst realitätsnah zu sein. Das System ist eher ein "langfristiges" Intraday-System, wobei von der Auslösung des Signals bis zum Triggern des Signals noch einige Zeit vergeht. Die bisherigen Tests mit C2 sind hierbei stets positiv gewesen. Ich verwende hierbei die von Investox angebotene C2-Schnittstelle.

Aber mal abgesehen von der C2-Problematik, meine Exit-Problem bleibt bestehen. Hast du eine Idee, woran das Auslösen dieser mir unbekannten Exit-Order liegen kann?

Vielen Dank für deine Bemühungen.

Grüße
Rainer

Bernd

Experte

Registrierungsdatum: 5. Juni 2005

Beiträge: 4 070

Wohnort: Iringsweg

9

Sonntag, 25. Dezember 2022, 12:14

Hallo Rainer

Wie schnell kommen denn die Signale laut Signalprotokoll, speziell um die Zeit herum, wenn Du Probleme hast mit der Signalumsetzung? Wie geschrieben, die C2-Schnittstelle ist weit entfernt von High Frequency, und ich denke immer noch, dass Überholer zu nicht nachvollziehbaren Resultaten führen könnten.

Du könntest auch versuchen, im ORM die Option "Stückzahl Depot/Handelsstem ableichen" zu aktivieren, diese Option scheint bisher nicht aktiv zu sein.
Gruss
Bernd

Rainer

Besucher

Registrierungsdatum: 30. November 2022

Beiträge: 10

10

Dienstag, 27. Dezember 2022, 20:55

Hallo Bernd,

Die Signale kommen ziemlich schnell, d.h. das nicht nachvollziehbare nach 1 Sekunde und das "richtige" direkt danach bei 2 Sekunden.

Mir wäre halt wichtig zu wissen, wo überhaupt dieses nicht nachvollziehbare Signal, das sofort zum gerade vorliegenden Marktpreis auslöst, herkommt. Das ist es was ich nicht verstehe.

Grüße
Rainer

Bernd

Experte

Registrierungsdatum: 5. Juni 2005

Beiträge: 4 070

Wohnort: Iringsweg

11

Mittwoch, 28. Dezember 2022, 11:28

Hallo Rainer

Wie sind denn die beiden fraglichen Signale im Signal-Protokoll in der Spalte "Signal" benannt?

Vielleicht kannst Du das Signalprotokoll auszugsweise noch hier anhängen?
Gruss
Bernd

Rainer

Besucher

Registrierungsdatum: 30. November 2022

Beiträge: 10

12

Donnerstag, 29. Dezember 2022, 13:02

Hallo Bernd,

ich habe es gerade mal wieder probiert. Hier ein Screenshot.


Rainer

Besucher

Registrierungsdatum: 30. November 2022

Beiträge: 10

13

Mittwoch, 15. Februar 2023, 13:53

Hallo,

ich muss mich leider nochmal melden, da mein Problem immer noch besteht. Ich habe aber ein paar Erkenntnisse gewonnen, die vielleicht zur Problemlösung beitragen könnten.

Zunächst ist es tatsächlich diese "andere" Order, die sich zeitlich vor meine "richtige" Order setzt. Ich würde das kurz an einem einfaches Systembeispiel erläutern:

Enter Long: High > Ref(High, -1)
Enter-Basis: Ref(High,-1) + 5
Ordereinstellungen: Stop (relativ zur Basis) und sonst steht alles auf 0.

D.h., sobald das laufende Hoch das Vortageshoch überschreitet, wird eine Order ausgelöst: Stop Long 5 Punkte über dem Hoch der Vortageskerze.
Dies funktioniert einwandfrei ! Alles Super.

Jetzt das Ganze diametral für den Exit:

Exit Long: Low <= Ref(Low, -1)
Exit-Basis: Ref(Low,-1) - 5
Ordereinstellungen: Stop (relativ zur Basis) und sonst steht alles auf 0.

Im Chart wird alles super angezeigt. Die Order wird allerdings sofort beim Erreichen des Exit-Long zum vorherrschenden Marktpreis abgesetzt.
Setzte ich den Stop in den Ordereinstellungen auf 5, so wird eine Stop zum vorherrschenden Marktpreis minus 5 abgesetzt.
Man könnte jetzt sagen, hey - dann nimm doch diese 5 als Einstellung und alles passt! Nein, das funktioniert leider so nicht. Vom Auslösen des Exit (Tagestief) bis zum Auslösen der Order vergeht Zeit -wenn auch nur eine Sekunde - in der sich der Marktpreis ändert und somit auch der Exit. Bewegt sich in dieser einen Sekunde der Markt bspw. 2 Punkte wieder hoch, wird eine Exit-Order 3 Punkte unter dem Tief der Vorkerze abgesetzt. Und schon würden HS und Depot nicht synchron laufen.

Das Ganze ist wie verhext, da ich einfach nicht rausfinde, woher die Order kommt. Ich habe nach und nach alle Haken im Ordermodul entfernt - keine Änderung. Ich habe auch die Begrenzung der Signalumsetzung auf 1 Signal pro Periode rausgenommen. Und siehe da, mein "richtiger" Exit erscheint. Aber bis dahin können schon HS und Depot auseinanderlaufen. Außerdem erscheint dieser "richtige" Exit auch nicht immer. Keine Ahnung warum, vielleicht finde ich es noch raus.

Als letztes ist mir noch folgendes aufgefallen: Sobald der Exit ausgelöst wird, also mit dem Erreichens des Vortiefs, wird die Zeitleiste grau. Man ist zwar Long, aber das sieht man so nicht direkt. Auch werden die Exit weiter angepasst, wenn sie sich ändern, in der Zeitleiste bleibt es grau. Fährt man mit der Maus drüber, wird "Out" signalisiert. Wird das Exit nun erreicht und der Trade geschlossen, ist die Leiste wieder grün als Zeichen des Longtrades. Ist das so normal bei Exits ???

So, genug für heute. Ich bedanke mich für eure Aufmerksamkeit und würde mich über ein Feedback wirklich sehr freuen.

Grüße
Rainer

Calde#79 Männlich

Besucher

Registrierungsdatum: 24. Oktober 2020

Beiträge: 16

Wohnort: Österreich Kärnten 9701

14

Mittwoch, 15. Februar 2023, 23:31

Hallo Rainer!
Leider kann ich dir keine Hilfestellung geben aber dein Problem hat Ähnlichkeit mit meinem (eines meiner Probleme, um genau zu sein ;) )Bei einigen Signalen des HS wird die Order ausgeführt und nach einigen Perioden verschwindet das Handelssignal und akustisch wird "Out" ausgegeben.Auch in der Handelssignal-Leiste verschwindet das Signal und wird grau. Entweder wird (wenn ich Glück habe) die Position geschlossen, oder die Position bleibt bis zum nächsten Signal offen.Wenn das Handelssignal bei offenen Trade verschwindet, sind auch alle Stops inaktiv (weil kein Handelssignal mehr vorhanden).Ist das bei dir auch so oder wieder was anderes? S. Foto.
LG Mario





Lenzelott Männlich

Experte

Registrierungsdatum: 30. Dezember 2002

Beiträge: 3 048

Wohnort: Giessen

15

Donnerstag, 16. Februar 2023, 01:36

Das ist alles viel zu kompliziert gedacht.

Da kannste einen entsprechenden "Exit" doch auch als Stop abbilden.
Und der Stop kann IMMER Nativ im Markt / bei IB liegen mit Order Plus.

Unter Optionen im Stop: Basis für Verlust-Gewinnberechnung lässt sich ein berechneter Wert eintragen, Bezugsart Dynamisch

Quellcode

1
global calc stoplevel:Ref(Low,-1) - 5;


Unter Anzeige des Stops: Verlust-Stop fortlaufend anpassen.

Backtest sollten dann (bis auf die Slipage) indentisch sein mit dem Realhandel
If you think it´s expensive to hire a professional, wait until you hire an amateur.

Investox

Administrator

Registrierungsdatum: 31. August 2002

Beiträge: 5 679

16

Freitag, 17. Februar 2023, 12:24

Hallo,

Zitat

Bei einigen Signalen des HS wird die Order ausgeführt und nach einigen Perioden verschwindet das Handelssignal und akustisch wird "Out" ausgegeben.Auch in der Handelssignal-Leiste verschwindet das Signal und wird grau.


Das klingt nach typischem "Flattersignal", siehe:
Siehe: https://investox.de/faqsignaleorders.html#a1963

Viele Grüße
Andreas Knöpfel

Rainer

Besucher

Registrierungsdatum: 30. November 2022

Beiträge: 10

17

Samstag, 18. Februar 2023, 22:38

Hallo Lenzelott,
vielen Dank für deine Antwort.
Unter Anzeige des Stops: Verlust-Stop fortlaufend anpassen.
Genau das geht leider mit Collective2 nicht. Eine bestehende Stop-Order kann dort nicht angepasst werden. Darum ja meine Versuche mit dem Exit.
Am einfachsten wäre eine Streichung der vorhandenen Stop-Order und das sofortige Setzen der neuen Order.

Gruß Rainer

Calde#79 Männlich

Besucher

Registrierungsdatum: 24. Oktober 2020

Beiträge: 16

Wohnort: Österreich Kärnten 9701

18

Dienstag, 21. Februar 2023, 22:42

Hallo Herr Knöpfel!
Danke für die Antwort.
Hallo,

Zitat

Bei einigen Signalen des HS wird die Order ausgeführt und nach einigen Perioden verschwindet das Handelssignal und akustisch wird "Out" ausgegeben.Auch in der Handelssignal-Leiste verschwindet das Signal und wird grau.


Das klingt nach typischem "Flattersignal", siehe:
Siehe: https://investox.de/faqsignaleorders.html#a1963

Viele Grüße
Andreas Knöpfel
Habe nochmal alles kontrolliert Regeln sind alle mit Ref(,-1) geschrieben und unter Überwachung habe ich die Option "Out Signale als Exit Signal verwenden" deaktiviert.
Während dessen bin ich aber bin auf eine "oder" verknüpfung gestoßen die das Problem verursachen könnte.
Muss diese Regel noch überdenken und bedanke mich vorerst für die Hilfen!

Lieben Gruß
Mario